aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorYuntao Xu <yuntaoxu@google.com>2021-05-04 23:53:12 +0000
committerAutomerger Merge Worker <android-build-automerger-merge-worker@system.gserviceaccount.com>2021-05-04 23:53:12 +0000
commitd9fbd5aa8286211e457f6fc432076a5662d527e0 (patch)
tree0b6a890691545518bc83b40f5330992b5d7ba234
parent64dc4694c1048ad840d4df6d2edba5075340ea71 (diff)
parent7f375887af24d7fcf8cdc7ee4e65fe1ae312eb2b (diff)
downloadTV-d9fbd5aa8286211e457f6fc432076a5662d527e0.tar.gz
Merge "Convert func/Android.mk to Android.bp" am: 05f052f3d7 am: 7f375887af
Original change: https://android-review.googlesource.com/c/platform/packages/apps/TV/+/1690696 Change-Id: I9673bb0e5a221bcf66d1da18dbfaadda800edafc
-rw-r--r--tests/func/Android.bp21
-rw-r--r--tests/func/Android.mk26
2 files changed, 21 insertions, 26 deletions
diff --git a/tests/func/Android.bp b/tests/func/Android.bp
new file mode 100644
index 00000000..d4085394
--- /dev/null
+++ b/tests/func/Android.bp
@@ -0,0 +1,21 @@
+package {
+ // See: http://go/android-license-faq
+ default_applicable_licenses: ["Android-Apache-2.0"],
+}
+
+android_test {
+ name: "TVFuncTests",
+ // Include all test java files.
+ srcs: ["src/**/*.java"],
+ static_libs: [
+ "androidx.test.runner",
+ "tv-test-common",
+ "ub-uiautomator",
+ ],
+ libs: ["android.test.base.stubs"],
+ instrumentation_for: "LiveTv",
+ sdk_version: "system_current",
+ optimize: {
+ enabled: false,
+ },
+}
diff --git a/tests/func/Android.mk b/tests/func/Android.mk
deleted file mode 100644
index 60290c2d..00000000
--- a/tests/func/Android.mk
+++ /dev/null
@@ -1,26 +0,0 @@
-LOCAL_PATH:= $(call my-dir)
-include $(CLEAR_VARS)
-
-LOCAL_MODULE_TAGS := tests
-
-
-# Include all test java files.
-LOCAL_SRC_FILES := $(call all-java-files-under, src)
-
-LOCAL_PACKAGE_NAME := TVFuncTests
-LOCAL_LICENSE_KINDS := SPDX-license-identifier-Apache-2.0
-LOCAL_LICENSE_CONDITIONS := notice
-
-LOCAL_STATIC_JAVA_LIBRARIES := \
- androidx.test.runner \
- tv-test-common \
- ub-uiautomator \
-
-LOCAL_JAVA_LIBRARIES := android.test.base.stubs
-
-LOCAL_INSTRUMENTATION_FOR := LiveTv
-
-LOCAL_SDK_VERSION := system_current
-
-LOCAL_PROGUARD_ENABLED := disabled
-include $(BUILD_PACKAGE)