aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorandroid-build-team Robot <android-build-team-robot@google.com>2021-05-07 01:08:31 +0000
committerandroid-build-team Robot <android-build-team-robot@google.com>2021-05-07 01:08:31 +0000
commit8084c344313c1af5dbee897e17df5f13964e06ba (patch)
tree868a864e39ae01800d823981ac3d3732ada4df5b
parentb70ef5b0b670aebfea51f99bc0c0c9e45eb2d7d7 (diff)
parent3c69d251f11d8f15349b44ccdda4a51769f656aa (diff)
downloadTV-8084c344313c1af5dbee897e17df5f13964e06ba.tar.gz
Snap for 7343210 from 3c69d251f11d8f15349b44ccdda4a51769f656aa to sc-release
Change-Id: Idb5827d8a3f47022dd8251fe91a58d5e1d448b03
-rw-r--r--jni/minijail/Android.bp32
-rw-r--r--jni/minijail/Android.mk32
2 files changed, 32 insertions, 32 deletions
diff --git a/jni/minijail/Android.bp b/jni/minijail/Android.bp
new file mode 100644
index 00000000..cb921159
--- /dev/null
+++ b/jni/minijail/Android.bp
@@ -0,0 +1,32 @@
+//
+// Copyright (C) 2017 The Android Open Source Project
+//
+// Licensed under the Apache License, Version 2.0 (the "License");
+// you may not use this file except in compliance with the License.
+// You may obtain a copy of the License at
+//
+// http://www.apache.org/licenses/LICENSE-2.0
+//
+// Unless required by applicable law or agreed to in writing, software
+// distributed under the License is distributed on an "AS IS" BASIS,
+// WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
+// See the License for the specific language governing permissions and
+// limitations under the License.
+//
+
+package {
+ // See: http://go/android-license-faq
+ default_applicable_licenses: ["Android-Apache-2.0"],
+}
+
+cc_library_shared {
+ name: "libminijail_jni",
+ srcs: ["minijail.cpp"],
+ stl: "none",
+ header_libs: ["jni_headers"],
+ static_libs: [
+ "libc++_static",
+ "libminijail",
+ ],
+ shared_libs: ["liblog"],
+}
diff --git a/jni/minijail/Android.mk b/jni/minijail/Android.mk
deleted file mode 100644
index 3d8e2b35..00000000
--- a/jni/minijail/Android.mk
+++ /dev/null
@@ -1,32 +0,0 @@
-#
-# Copyright (C) 2017 The Android Open Source Project
-#
-# Licensed under the Apache License, Version 2.0 (the "License");
-# you may not use this file except in compliance with the License.
-# You may obtain a copy of the License at
-#
-# http://www.apache.org/licenses/LICENSE-2.0
-#
-# Unless required by applicable law or agreed to in writing, software
-# distributed under the License is distributed on an "AS IS" BASIS,
-# WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
-# See the License for the specific language governing permissions and
-# limitations under the License.
-#
-
-LOCAL_PATH := $(call my-dir)
-
-# --------------------------------------------------------------
-include $(CLEAR_VARS)
-
-LOCAL_MODULE := libminijail_jni
-LOCAL_LICENSE_KINDS := SPDX-license-identifier-Apache-2.0
-LOCAL_LICENSE_CONDITIONS := notice
-LOCAL_SRC_FILES := minijail.cpp
-LOCAL_CFLAGS := -Wall -Werror
-LOCAL_CXX_STL := none
-LOCAL_HEADER_LIBRARIES := jni_headers
-LOCAL_STATIC_LIBRARIES := libc++_static libminijail
-LOCAL_LDLIBS := -llog
-
-include $(BUILD_SHARED_LIBRARY)