aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorYuntao Xu <yuntaoxu@google.com>2021-11-02 22:01:20 +0000
committerAutomerger Merge Worker <android-build-automerger-merge-worker@system.gserviceaccount.com>2021-11-02 22:01:20 +0000
commitd33ea13622885c534b70d090be791b244ba0a892 (patch)
treee094c5aaa8f5d5c645530c60e9aa3462a163ffa7
parent1530db7857308e2e4e8e69d7d2b42e4cf42062dc (diff)
parent80c57e68caf55a8b092634cf57fbfadbbd9101b1 (diff)
downloadTV-d33ea13622885c534b70d090be791b244ba0a892.tar.gz
Merge "Convert input/Android.mk to Android.bp" am: 8db1b5ae23 am: db7d4343c0 am: 2f31ab0fe9 am: 80c57e68ca
Original change: https://android-review.googlesource.com/c/platform/packages/apps/TV/+/1867138 Change-Id: I5219b477aad473ac94c0ef2cd4413a38a7a43bb7
-rw-r--r--tests/input/Android.bp46
-rw-r--r--tests/input/Android.mk31
2 files changed, 46 insertions, 31 deletions
diff --git a/tests/input/Android.bp b/tests/input/Android.bp
new file mode 100644
index 00000000..31e9e098
--- /dev/null
+++ b/tests/input/Android.bp
@@ -0,0 +1,46 @@
+// Copyright (C) 2021 Google Inc.
+//
+// Licensed under the Apache License, Version 2.0 (the "License");
+// you may not use this file except in compliance with the License.
+// You may obtain a copy of the License at
+//
+// http://www.apache.org/licenses/LICENSE-2.0
+//
+// Unless required by applicable law or agreed to in writing, software
+// distributed under the License is distributed on an "AS IS" BASIS,
+// WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
+// See the License for the specific language governing permissions and
+// limitations under the License.
+
+package {
+ // See: http://go/android-license-faq
+ default_applicable_licenses: [
+ "Android-Apache-2.0",
+ ],
+}
+
+android_app {
+ name: "TVTestInput",
+ srcs: ["src/**/*.java"],
+ optimize: {
+ enabled: false,
+ },
+ // Overlay view related functionality requires system APIs.
+ sdk_version: "system_current",
+ static_libs: [
+ "tv-test-common",
+ "tv-common",
+ ],
+ // Disable dexpreopt and <uses-library> check for test.
+ enforce_uses_libs: false,
+ dex_preopt: {
+ enabled: false,
+ },
+ resource_dirs: [
+ "res",
+ ],
+ aaptflags: [
+ "--auto-add-overlay",
+ "--extra-packages com.android.tv.testing",
+ ],
+}
diff --git a/tests/input/Android.mk b/tests/input/Android.mk
deleted file mode 100644
index 4011dec8..00000000
--- a/tests/input/Android.mk
+++ /dev/null
@@ -1,31 +0,0 @@
-LOCAL_PATH:= $(call my-dir)
-include $(CLEAR_VARS)
-
-LOCAL_SRC_FILES := $(call all-java-files-under, src)
-
-LOCAL_PACKAGE_NAME := TVTestInput
-LOCAL_LICENSE_KINDS := SPDX-license-identifier-Apache-2.0
-LOCAL_LICENSE_CONDITIONS := notice
-LOCAL_MODULE_TAGS := optional
-LOCAL_PROGUARD_ENABLED := disabled
-# Overlay view related functionality requires system APIs.
-LOCAL_SDK_VERSION := system_current
-LOCAL_PROGUARD_ENABLED := disabled
-
-LOCAL_STATIC_JAVA_LIBRARIES := \
- tv-test-common \
- tv-common
-
-# Disable dexpreopt and <uses-library> check for test.
-LOCAL_ENFORCE_USES_LIBRARIES := false
-LOCAL_DEX_PREOPT := false
-
-LOCAL_RESOURCE_DIR := $(LOCAL_PATH)/../common/res $(LOCAL_PATH)/res
-LOCAL_AAPT_FLAGS := --auto-add-overlay \
- --extra-packages com.android.tv.testing
-
-include $(BUILD_PACKAGE)
-
-ifneq ($(filter TV,$(TARGET_BUILD_APPS)),)
- $(call dist-for-goals,apps_only,$(LOCAL_BUILT_MODULE):$(LOCAL_PACKAGE_NAME).apk)
-endif