aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorYuntao Xu <yuntaoxu@google.com>2021-10-19 16:30:22 -0700
committerYuntao Xu <yuntaoxu@google.com>2021-10-28 11:45:35 -0700
commit2d7bf9da8aa3c9037a2d705fc77d64fe3df5333e (patch)
tree6823ff48cffcfdcd5a52bb7135c365c96b66fb68
parent8aad9d2eedd214747b8191e9581d82629d4d34e0 (diff)
downloadTV-2d7bf9da8aa3c9037a2d705fc77d64fe3df5333e.tar.gz
Convert input/Android.mk to Android.bp
1. Converted the Make file to a Soong one; 2. The apk built with Soong has more files than that built with Make in the res/ directory, due to that Soong includes more properties or files than Make, which is considered OKay for the conversion. Bug: 203606453 Test: compared the two apk files built by Make and Soong Test: TreeHugger Change-Id: Ib5fc8fd0876ff5cd6f9a7ab46cf1ccf824359249
-rw-r--r--tests/input/Android.bp46
-rw-r--r--tests/input/Android.mk31
2 files changed, 46 insertions, 31 deletions
diff --git a/tests/input/Android.bp b/tests/input/Android.bp
new file mode 100644
index 00000000..31e9e098
--- /dev/null
+++ b/tests/input/Android.bp
@@ -0,0 +1,46 @@
+// Copyright (C) 2021 Google Inc.
+//
+// Licensed under the Apache License, Version 2.0 (the "License");
+// you may not use this file except in compliance with the License.
+// You may obtain a copy of the License at
+//
+// http://www.apache.org/licenses/LICENSE-2.0
+//
+// Unless required by applicable law or agreed to in writing, software
+// distributed under the License is distributed on an "AS IS" BASIS,
+// WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
+// See the License for the specific language governing permissions and
+// limitations under the License.
+
+package {
+ // See: http://go/android-license-faq
+ default_applicable_licenses: [
+ "Android-Apache-2.0",
+ ],
+}
+
+android_app {
+ name: "TVTestInput",
+ srcs: ["src/**/*.java"],
+ optimize: {
+ enabled: false,
+ },
+ // Overlay view related functionality requires system APIs.
+ sdk_version: "system_current",
+ static_libs: [
+ "tv-test-common",
+ "tv-common",
+ ],
+ // Disable dexpreopt and <uses-library> check for test.
+ enforce_uses_libs: false,
+ dex_preopt: {
+ enabled: false,
+ },
+ resource_dirs: [
+ "res",
+ ],
+ aaptflags: [
+ "--auto-add-overlay",
+ "--extra-packages com.android.tv.testing",
+ ],
+}
diff --git a/tests/input/Android.mk b/tests/input/Android.mk
deleted file mode 100644
index 4011dec8..00000000
--- a/tests/input/Android.mk
+++ /dev/null
@@ -1,31 +0,0 @@
-LOCAL_PATH:= $(call my-dir)
-include $(CLEAR_VARS)
-
-LOCAL_SRC_FILES := $(call all-java-files-under, src)
-
-LOCAL_PACKAGE_NAME := TVTestInput
-LOCAL_LICENSE_KINDS := SPDX-license-identifier-Apache-2.0
-LOCAL_LICENSE_CONDITIONS := notice
-LOCAL_MODULE_TAGS := optional
-LOCAL_PROGUARD_ENABLED := disabled
-# Overlay view related functionality requires system APIs.
-LOCAL_SDK_VERSION := system_current
-LOCAL_PROGUARD_ENABLED := disabled
-
-LOCAL_STATIC_JAVA_LIBRARIES := \
- tv-test-common \
- tv-common
-
-# Disable dexpreopt and <uses-library> check for test.
-LOCAL_ENFORCE_USES_LIBRARIES := false
-LOCAL_DEX_PREOPT := false
-
-LOCAL_RESOURCE_DIR := $(LOCAL_PATH)/../common/res $(LOCAL_PATH)/res
-LOCAL_AAPT_FLAGS := --auto-add-overlay \
- --extra-packages com.android.tv.testing
-
-include $(BUILD_PACKAGE)
-
-ifneq ($(filter TV,$(TARGET_BUILD_APPS)),)
- $(call dist-for-goals,apps_only,$(LOCAL_BUILT_MODULE):$(LOCAL_PACKAGE_NAME).apk)
-endif