aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJi-Hwan Lee <jihwan@google.com>2014-08-05 07:11:53 +0000
committerAndroid (Google) Code Review <android-gerrit@google.com>2014-08-05 00:03:09 +0000
commitf14e7a958f78c7dbbff993f0c141c93126b807e4 (patch)
tree68d044243b1d36484ea80fa621439bd7a4aee2cd
parent7931fec967654d46d0312568936764cf86fa4e2d (diff)
parent951df7fef03dfa9e60f4f44dffe095e7a02019e5 (diff)
downloadTV-f14e7a958f78c7dbbff993f0c141c93126b807e4.tar.gz
Merge "Add SampleTvInput and FakeHardwareTvInput to build server result" into lmp-dev
-rw-r--r--hwsample/Android.mk6
-rw-r--r--sample/Android.mk6
2 files changed, 12 insertions, 0 deletions
diff --git a/hwsample/Android.mk b/hwsample/Android.mk
index ea779e8c..818b7276 100644
--- a/hwsample/Android.mk
+++ b/hwsample/Android.mk
@@ -26,3 +26,9 @@ LOCAL_PRIVILEGED_MODULE := true
LOCAL_MODULE_TAGS := optional
include $(BUILD_PACKAGE)
+
+ifeq ($(PRODUCT_IS_ATV),true)
+ ifneq ($(PRODUCT_IS_ATV_SDK),true)
+ $(call dist-for-goals,dist_files,$(LOCAL_BUILT_MODULE):FakeHardwareTvInput.apk)
+ endif
+endif
diff --git a/sample/Android.mk b/sample/Android.mk
index b06c2ec1..03f4a51d 100644
--- a/sample/Android.mk
+++ b/sample/Android.mk
@@ -8,3 +8,9 @@ LOCAL_MODULE_TAGS := optional
LOCAL_PROGUARD_ENABLED := disabled
include $(BUILD_PACKAGE)
+
+ifeq ($(PRODUCT_IS_ATV),true)
+ ifneq ($(PRODUCT_IS_ATV_SDK),true)
+ $(call dist-for-goals,dist_files,$(LOCAL_BUILT_MODULE):SampleTvInput.apk)
+ endif
+endif