aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPaul Duffin <paulduffin@google.com>2017-06-13 12:28:59 +0100
committerPaul Duffin <paulduffin@google.com>2017-06-13 12:28:59 +0100
commit7416628255cd3c95b6ffecd331fbb0add9c1eea9 (patch)
treeb6a4696e3a259d1dcebfa3c52080dc5096c10d6b
parent7e62ba8256178e11615968918013f8db8985fde0 (diff)
downloadTV-7416628255cd3c95b6ffecd331fbb0add9c1eea9.tar.gz
Fix dependencies of packages that target earlier releasesandroid-o-preview-4android-o-iot-preview-5o-iot-preview-5
A previous change added legacy-android-test as a static dependency to all packages that build against the current, test_current or system_current and failed to compile when the junit and android.test classes were removed from the API. Unfortunately, those changes did not take into account that some of those packages target earlier API versions and so will always have the classes available at runtime. This change replaces those static dependencies with dynamic dependencies for any package that targets an earlier API version. The file changes were made automatically by a tool that constructed and then analyzed a full dependency graph of all the Android Java modules. The individual changes were checked manually to ensure that the changes matched the intent. The affected modules were built against an API with the junit and android.test classes removed. Any issues found during this process resulted in either the tool being updated to address the issue or a separate change being made to fix an existing problem with the build. A sample of the affected packages were run to ensure that they worked as expected at runtime; no issues were found during testing. The following change descriptions were generated automatically and so may be a little repetitive. They are provided to give the reviewer enough information to check the comments match what has actually been changed and check the reasoning behind the changes. * Android.mk Added 'junit' to LOCAL_JAVA_LIBRARIES because module LiveTv builds against 'LOCAL_SDK_VERSION := system_current' and uses classes from package junit (possibly indirectly) so will no longer compile once they are removed from the API. It was not added to LOCAL_STATIC_JAVA_LIBRARIES because LiveTv's manifest file (AndroidManifest.xml) targets API level 23 and uses the android.test.runner library which will provide the classes dynamically at runtime. * tests/func/Android.mk Added 'legacy-android-test' to LOCAL_JAVA_LIBRARIES because module TVFuncTests builds against 'LOCAL_SDK_VERSION := current' and uses classes from package android.test (possibly indirectly) so will no longer compile once they are removed from the API. It was not added to LOCAL_STATIC_JAVA_LIBRARIES because TVFuncTests's manifest file (AndroidManifest.xml) targets API level 23 and uses the android.test.runner library which will provide the classes dynamically at runtime. * tests/jank/Android.mk Added 'legacy-android-test' to LOCAL_JAVA_LIBRARIES because module TVJankTests builds against 'LOCAL_SDK_VERSION := current' and uses classes from package android.test (possibly indirectly) so will no longer compile once they are removed from the API. It was not added to LOCAL_STATIC_JAVA_LIBRARIES because TVJankTests's manifest file (AndroidManifest.xml) targets API level 23 and uses the android.test.runner library which will provide the classes dynamically at runtime. * tests/unit/Android.mk Added 'android.test.mock.sdk' and 'legacy-android-test' to LOCAL_JAVA_LIBRARIES because module TVUnitTests builds against 'LOCAL_SDK_VERSION := system_current' and uses classes from packages android.test and android.test.mock (possibly indirectly) so will no longer compile once they are removed from the API. They were not added to LOCAL_STATIC_JAVA_LIBRARIES because TVUnitTests's manifest file (AndroidManifest.xml) targets API level 23 and uses the android.test.runner library which will provide the classes dynamically at runtime. Dependency 'android.test.mock.sdk' is used instead of 'android.test.mock' because module TVUnitTests builds against the API not internal jars and so should use libraries that build against the API not internal jars. A future change will replace the dependency on 'legacy-android-test', which builds against the internal jars with a dependency on 'android.legacy.test' which will build against the API. Bug: 30188076 Test: make checkbuild and ran a sample of tests Change-Id: Ib64e14d0d20b6f3cc453e0660496fa6526be902d
-rw-r--r--Android.mk2
-rw-r--r--tests/func/Android.mk2
-rw-r--r--tests/jank/Android.mk2
-rw-r--r--tests/unit/Android.mk2
4 files changed, 8 insertions, 0 deletions
diff --git a/Android.mk b/Android.mk
index 5884c5c3..577052d3 100644
--- a/Android.mk
+++ b/Android.mk
@@ -62,6 +62,8 @@ LOCAL_STATIC_JAVA_LIBRARIES := \
+LOCAL_JAVA_LIBRARIES := junit
+
LOCAL_JAVACFLAGS := -Xlint:deprecation -Xlint:unchecked
LOCAL_AAPT_FLAGS := --auto-add-overlay \
diff --git a/tests/func/Android.mk b/tests/func/Android.mk
index e89ba25b..b0c5ad1c 100644
--- a/tests/func/Android.mk
+++ b/tests/func/Android.mk
@@ -14,6 +14,8 @@ LOCAL_STATIC_JAVA_LIBRARIES := \
tv-test-common \
ub-uiautomator \
+LOCAL_JAVA_LIBRARIES := legacy-android-test
+
LOCAL_INSTRUMENTATION_FOR := LiveTv
LOCAL_SDK_VERSION := current
diff --git a/tests/jank/Android.mk b/tests/jank/Android.mk
index b71ea1b7..210a75ea 100644
--- a/tests/jank/Android.mk
+++ b/tests/jank/Android.mk
@@ -15,6 +15,8 @@ LOCAL_STATIC_JAVA_LIBRARIES := \
ub-janktesthelper \
ub-uiautomator \
+LOCAL_JAVA_LIBRARIES := legacy-android-test
+
LOCAL_INSTRUMENTATION_FOR := LiveTv
LOCAL_SDK_VERSION := current
diff --git a/tests/unit/Android.mk b/tests/unit/Android.mk
index 7ed100d0..f53220de 100644
--- a/tests/unit/Android.mk
+++ b/tests/unit/Android.mk
@@ -12,6 +12,8 @@ LOCAL_STATIC_JAVA_LIBRARIES := \
mockito-target \
tv-test-common \
+LOCAL_JAVA_LIBRARIES := android.test.mock.sdk legacy-android-test
+
LOCAL_PACKAGE_NAME := TVUnitTests
LOCAL_INSTRUMENTATION_FOR := LiveTv