aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDan Willemsen <dwillemsen@google.com>2016-09-17 00:09:51 +0000
committerandroid-build-merger <android-build-merger@google.com>2016-09-17 00:09:51 +0000
commitb15401fe289a596a01f606e5147bd65a442826a6 (patch)
treeed156f28a158ea6da43fd42925e6eea979ed1e63
parent10feebef03fc8689f701de7ec3b60733e5cf5d4c (diff)
parentcfaee0edf03d9e6f4af7b14b368a0ea1ba9499cf (diff)
downloadTV-b15401fe289a596a01f606e5147bd65a442826a6.tar.gz
Don't add BUILD_NUMBER to version for platform builds am: 04bf2c2a3e
am: cfaee0edf0 Change-Id: Ia9afaa42bc1cfd80694dc9946fbd2ef45b57371b
-rw-r--r--version.mk5
1 files changed, 5 insertions, 0 deletions
diff --git a/version.mk b/version.mk
index e0d8cd02..49048f2a 100644
--- a/version.mk
+++ b/version.mk
@@ -87,11 +87,13 @@ base_version_density := 0
version_code_package := $(code_version_major)$(base_version_minor)$(code_version_build)$(base_version_buildtype)$(base_version_arch)$(base_version_density)
# The version name scheme for the package apk is:
+# - For platform builds: M.mm.bbb
# - For eng build (t=0): M.mm.bbb eng.$(USER)-hh-date-ad
# - For build server (t=1): M.mm.bbb (nnnnnn-ad)
# where nnnnnn is the build number from the build server (no zero-padding)
# and hh is the git hash
# On eng builds, the BUILD_NUMBER has the user and timestamp inline
+ifdef TARGET_BUILD_APPS
ifneq "" "$(filter eng.%,$(BUILD_NUMBER))"
git_hash := $(shell git --git-dir $(LOCAL_PATH)/.git log -n 1 --pretty=format:%h)
date_string := $(shell date +%m%d%y_%H%M%S)
@@ -99,6 +101,9 @@ ifneq "" "$(filter eng.%,$(BUILD_NUMBER))"
else
version_name_package := $(base_version_major).$(base_version_minor).$(code_version_build) ($(BUILD_NUMBER)-$(base_version_arch)$(base_version_density))
endif
+else # !TARGET_BUILD_APPS
+ version_name_package := $(base_version_major).$(base_version_minor).$(code_version_build)
+endif
# Cleanup the locals
code_version_major :=