aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPaul Duffin <paulduffin@google.com>2017-06-15 11:01:08 +0100
committerPaul Duffin <paulduffin@google.com>2017-06-15 11:01:08 +0100
commit0e0082535dc276086ee61ac156581a20e86609e7 (patch)
treebc9f4f21c93e0021a266c3e2793c54e9b81c1b53
parentab87bbbb4493e268e4fb40d9d56d4c17ee022e47 (diff)
downloadTV-0e0082535dc276086ee61ac156581a20e86609e7.tar.gz
Fix dependencies of packages that target earlier releasesandroid-o-mr1-preview-2android-o-mr1-preview-1
A previous change added legacy-android-test as a static dependency to all packages that build against the current, test_current or system_current and failed to compile when the junit and android.test classes were removed from the API. Unfortunately, those changes did not take into account that some of those packages target earlier API versions and so will always have the classes available at runtime. This change replaces those static dependencies with dynamic dependencies for any package that targets an earlier API version. The file changes were made automatically by a tool that constructed and then analyzed a full dependency graph of all the Android Java modules. The individual changes were checked manually to ensure that the changes matched the intent. The affected modules were built against an API with the junit and android.test classes removed. Any issues found during this process resulted in either the tool being updated to address the issue or a separate change being made to fix an existing problem with the build. A sample of the affected packages were run to ensure that they worked as expected at runtime; no issues were found during testing. The following change descriptions were generated automatically and so may be a little repetitive. They are provided to give the reviewer enough information to check the comments match what has actually been changed and check the reasoning behind the changes. * Android.mk Removed legacy-android-test from LOCAL_STATIC_JAVA_LIBRARIES because LiveTv's manifest file (AndroidManifest.xml) targets API level 23 and dynamically includes the android.test.runner library at runtime so there is no point in statically including the classes. It was not added to LOCAL_JAVA_LIBRARIES because module LiveTv does not have any dependencies on android.test classes Bug: 30188076 Test: make checkbuild and ran a sample of tests Change-Id: I642ff8a4e8c8198d3749f4392e24197583be210c
-rw-r--r--Android.mk3
1 files changed, 0 insertions, 3 deletions
diff --git a/Android.mk b/Android.mk
index 435b3d27..18468adc 100644
--- a/Android.mk
+++ b/Android.mk
@@ -57,9 +57,6 @@ LOCAL_STATIC_JAVA_LIBRARIES := \
icu4j-usbtuner \
lib-exoplayer \
tv-common \
- legacy-android-test \
- junit
-
LOCAL_JAVA_LIBRARIES := junit