aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPaul Duffin <paulduffin@google.com>2017-03-01 13:21:11 +0000
committerPaul Duffin <paulduffin@google.com>2017-03-01 13:21:11 +0000
commit79f2e98d97cde644bb1b0327a4d3bfeaf8dde8c7 (patch)
treebeeb9436a6c16b12e531e81a6a44831b5d509ede
parent90408d018b9a466fa3d29470bb081204c29bce09 (diff)
downloadTV-79f2e98d97cde644bb1b0327a4d3bfeaf8dde8c7.tar.gz
Prepare for removal of junit and android.test classes from Android API (step 1)android-o-preview-1o-preview
In preparation for removing junit and android.test classes from the Android API this change adds explicit dependencies on junit and/or legacy-android-test to ensure that modules will compile properly once it is removed. Care was taken to ensure that any targets that depended, directly or indirectly, on android-support-test did not also depend on junit or hamcrest as they conflict with the versions embedded within android-support-test. Bug: 30188076 Test: make checkbuild Change-Id: I8492291989094622107a4b5447ce797526cb639b
-rw-r--r--Android.mk3
1 files changed, 2 insertions, 1 deletions
diff --git a/Android.mk b/Android.mk
index 31fcec21..5a5479b6 100644
--- a/Android.mk
+++ b/Android.mk
@@ -57,7 +57,8 @@ LOCAL_STATIC_JAVA_LIBRARIES := \
icu4j-usbtuner \
lib-exoplayer \
tv-common \
-
+ legacy-android-test \
+ junit
LOCAL_JAVACFLAGS := -Xlint:deprecation -Xlint:unchecked