aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDan Willemsen <dwillemsen@google.com>2019-01-02 14:22:49 -0800
committerDan Willemsen <dwillemsen@google.com>2019-01-02 14:22:49 -0800
commit8c664c5cc7e60d7e4d9adfbe4b21514aa753b5f0 (patch)
tree4cbf977c1e9f1070da74208caa59deebe8c24f0a
parent44297f1efde250dc789eeceb090fe3b3dab87894 (diff)
downloadTV-oreo-mr1-iot-release.tar.gz
USER may be "nobody" if the build is sandboxed. BUILD_USERNAME will have the original value in all cases. Bug: 122270019 Test: none Change-Id: Ic64f842864a9e79ea2179228370bb4fd92541d20
-rw-r--r--version.mk2
1 files changed, 1 insertions, 1 deletions
diff --git a/version.mk b/version.mk
index 375249e9..90fe55ec 100644
--- a/version.mk
+++ b/version.mk
@@ -97,7 +97,7 @@ ifdef TARGET_BUILD_APPS
ifeq ($(strip $(HAS_BUILD_NUMBER)),false)
git_hash := $(shell git --git-dir $(LOCAL_PATH)/.git log -n 1 --pretty=format:%h)
date_string := $(shell date +%Y-%m-%d)
- version_name_package := $(base_version_major).$(base_version_minor).$(code_version_build) (eng.$(USER).$(git_hash).$(date_string)-$(base_version_arch)$(base_version_density))
+ version_name_package := $(base_version_major).$(base_version_minor).$(code_version_build) (eng.$(BUILD_USERNAME).$(git_hash).$(date_string)-$(base_version_arch)$(base_version_density))
else
version_name_package := $(base_version_major).$(base_version_minor).$(code_version_build) ($(BUILD_NUMBER_FROM_FILE)-$(base_version_arch)$(base_version_density))
endif