aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPaul Duffin <paulduffin@google.com>2017-12-13 13:14:07 +0000
committerPaul Duffin <paulduffin@google.com>2017-12-13 14:27:51 +0000
commiteb190dc7fdd9e349f50084b10c655c135befdcfb (patch)
tree4359d93e388940ce3a2dabdc663b06a2611fd31f
parente506854dbc4919bf79ca4c705a04d6e225704d3e (diff)
downloadTV-eb190dc7fdd9e349f50084b10c655c135befdcfb.tar.gz
Add android.test.runner.stubs dependency
In preparation for the removal of the non-junit classes in the android.test.runner library from the android.jar this adds a dependency on android.test.runner.stubs to ensure this code will continue to compile. The following change descriptions were generated automatically and so may be a little repetitive. They are provided to give the reviewer enough information to check the comments match what has actually been changed and check the reasoning behind the changes. * tests/unit/Android.mk Added 'android.test.runner.stubs' to LOCAL_JAVA_LIBRARIES because TVUnitTests's will needs them in order to compile once its classes are removed from the system_current SDK on which it currently depends. Bug: 30188076 Test: make checkbuild Change-Id: I6de67f924f16d7450098ecf19c21d5ce2e0c73fd
-rw-r--r--tests/unit/Android.mk1
1 files changed, 1 insertions, 0 deletions
diff --git a/tests/unit/Android.mk b/tests/unit/Android.mk
index 3632fe94..cb3af303 100644
--- a/tests/unit/Android.mk
+++ b/tests/unit/Android.mk
@@ -12,6 +12,7 @@ LOCAL_STATIC_JAVA_LIBRARIES := \
mockito-target \
tv-test-common \
+LOCAL_JAVA_LIBRARIES := android.test.runner.stubs
LOCAL_RESOURCE_DIR := $(LOCAL_PATH)/../common/res