aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorYuntao Xu <yuntaoxu@google.com>2021-05-18 18:00:45 +0000
committerGerrit Code Review <noreply-gerritcodereview@google.com>2021-05-18 18:00:45 +0000
commit9522794f500059514e71349675852b745e97f4a9 (patch)
treed69fd7baf971865dfbc97cdd6b93dc4526853951
parent1ea232f323eafdfa9dd48c1cf513aadb9d509e49 (diff)
parentf85440d49d10fb3022d9ff16cef64042500bacae (diff)
downloadTV-9522794f500059514e71349675852b745e97f4a9.tar.gz
Merge "Convert jank/Android.mk to Android.bp"
-rw-r--r--tests/jank/Android.bp22
-rw-r--r--tests/jank/Android.mk27
2 files changed, 22 insertions, 27 deletions
diff --git a/tests/jank/Android.bp b/tests/jank/Android.bp
new file mode 100644
index 00000000..1cea734b
--- /dev/null
+++ b/tests/jank/Android.bp
@@ -0,0 +1,22 @@
+package {
+ // See: http://go/android-license-faq
+ default_applicable_licenses: ["Android-Apache-2.0"],
+}
+
+android_test {
+ name: "TVJankTests",
+ // Include all test java files.
+ srcs: ["src/**/*.java"],
+ static_libs: [
+ "androidx.test.runner",
+ "tv-test-common",
+ "ub-janktesthelper",
+ "ub-uiautomator",
+ ],
+ libs: ["android.test.base.stubs"],
+ instrumentation_for: "LiveTv",
+ sdk_version: "system_current",
+ optimize: {
+ enabled: false,
+ },
+}
diff --git a/tests/jank/Android.mk b/tests/jank/Android.mk
deleted file mode 100644
index 9c52840d..00000000
--- a/tests/jank/Android.mk
+++ /dev/null
@@ -1,27 +0,0 @@
-LOCAL_PATH:= $(call my-dir)
-include $(CLEAR_VARS)
-
-LOCAL_MODULE_TAGS := tests
-
-
-# Include all test java files.
-LOCAL_SRC_FILES := $(call all-java-files-under, src)
-
-LOCAL_PACKAGE_NAME := TVJankTests
-LOCAL_LICENSE_KINDS := SPDX-license-identifier-Apache-2.0
-LOCAL_LICENSE_CONDITIONS := notice
-
-LOCAL_STATIC_JAVA_LIBRARIES := \
- androidx.test.runner \
- tv-test-common \
- ub-janktesthelper \
- ub-uiautomator \
-
-LOCAL_JAVA_LIBRARIES := android.test.base.stubs
-
-LOCAL_INSTRUMENTATION_FOR := LiveTv
-
-LOCAL_SDK_VERSION := system_current
-LOCAL_PROGUARD_ENABLED := disabled
-
-include $(BUILD_PACKAGE)