aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorColin Cross <ccross@android.com>2018-06-14 15:59:32 -0700
committerColin Cross <ccross@android.com>2018-06-14 16:00:26 -0700
commit5fdc24aa6cc0acfd6a2d5939862e6edbe14f1ef6 (patch)
tree7f3690ac41e33d50f82b14cabab8efaa104f212b
parent17850fe0bfcfed514c3e7a346a93f09c648abc83 (diff)
downloadTV-5fdc24aa6cc0acfd6a2d5939862e6edbe14f1ef6.tar.gz
Set LOCAL_MIN_SDK_VERSION in tv-common so that the build system doesn't raise the minSdkVersion value specified in the manifest, which causes ManifestMerger to error when trying to merge it into a package that specifies a lower minSdkVersion. Bug: 78447299 Test: m java Change-Id: Id49101542185ee5e0dc8c06928126e2f36c26f5c
-rw-r--r--common/Android.mk2
1 files changed, 2 insertions, 0 deletions
diff --git a/common/Android.mk b/common/Android.mk
index ff19392e..e1d10c7b 100644
--- a/common/Android.mk
+++ b/common/Android.mk
@@ -20,6 +20,8 @@ LOCAL_SHARED_ANDROID_LIBRARIES := \
android-support-v7-recyclerview \
android-support-v17-leanback \
+LOCAL_MIN_SDK_VERSION := 23
+
include $(LOCAL_PATH)/buildconfig.mk
include $(BUILD_STATIC_JAVA_LIBRARY)