aboutsummaryrefslogtreecommitdiff
path: root/Android.mk
diff options
context:
space:
mode:
authorNick Chalko <nchalko@google.com>2015-12-09 13:48:17 -0800
committerNick Chalko <nchalko@google.com>2015-12-11 15:09:19 -0800
commit1abddd9f6225298066094e20a6c29061b6af4590 (patch)
tree97d701f8681cca9939c86e5e61523775d4c13aea /Android.mk
parent7d67089aa1e9aa2123c3cd2f386d7019a1544db1 (diff)
downloadTV-1abddd9f6225298066094e20a6c29061b6af4590.tar.gz
Sync to ub-tv-heroes at 1.08.301
source change id If9b64d7bbc6e8f77b360e502d34e5452775c0402 Change-Id: I4ffe87911cb85e54880d1d918d1b8fb7bb8cfb7d
Diffstat (limited to 'Android.mk')
-rw-r--r--Android.mk18
1 files changed, 14 insertions, 4 deletions
diff --git a/Android.mk b/Android.mk
index 9558c0e0..5628c03c 100644
--- a/Android.mk
+++ b/Android.mk
@@ -38,10 +38,10 @@ LOCAL_PRIVILEGED_MODULE := true
LOCAL_SDK_VERSION := system_current
LOCAL_RESOURCE_DIR := \
- $(TOP)/prebuilts/sdk/current/support/v7/recyclerview/res \
- $(TOP)/prebuilts/sdk/current/support/v17/leanback/res \
+ $(LOCAL_PATH)/res \
$(LOCAL_PATH)/common/res \
- $(LOCAL_PATH)/res
+ $(TOP)/prebuilts/sdk/current/support/v17/leanback/res \
+ $(TOP)/prebuilts/sdk/current/support/v7/recyclerview/res \
LOCAL_STATIC_JAVA_LIBRARIES := \
android-support-annotations \
@@ -49,7 +49,7 @@ LOCAL_STATIC_JAVA_LIBRARIES := \
android-support-v7-palette \
android-support-v7-recyclerview \
android-support-v17-leanback \
- tv-common
+ tv-common \
LOCAL_JAVACFLAGS := -Xlint:deprecation -Xlint:unchecked
@@ -63,6 +63,16 @@ LOCAL_AAPT_FLAGS := --auto-add-overlay \
LOCAL_PROGUARD_FLAG_FILES := proguard.flags
+# Build directives for USB tuner
+# Ensures the apk built with platform contains the native binaries,
+# hence generates the same apk as the one built as an unbundled app.
+ifeq ($(TARGET_BUILD_APPS),)
+ LOCAL_MODULE_TAGS := samples
+endif
+LOCAL_RESOURCE_DIR += $(LOCAL_PATH)/usbtuner/res
+LOCAL_STATIC_JAVA_LIBRARIES += usbtuner-tvinput
+LOCAL_JNI_SHARED_LIBRARIES := libusbtuner_jni
+LOCAL_AAPT_FLAGS += --extra-packages com.android.usbtuner
include $(BUILD_PACKAGE)