aboutsummaryrefslogtreecommitdiff
path: root/Android.mk
diff options
context:
space:
mode:
authorYoungsang Cho <youngsang@google.com>2014-04-17 18:44:13 -0700
committerYoungsang Cho <youngsang@google.com>2014-04-22 13:58:14 -0700
commit3f07ce6c09b77e0c9224a16a4c73c8750ff8a07b (patch)
tree100ae34d8053c99d4831b6f21f0d54676044e150 /Android.mk
parent12f0705c6a8093543fc33bc7e85070f6e13fbe6b (diff)
downloadTV-3f07ce6c09b77e0c9224a16a4c73c8750ff8a07b.tar.gz
Initial check-in of TV app
TV is an app playing TV based on TV input framework. The app has basic TV features : Channel up/down, input change, input name configuration, and so on. Change-Id: If9a3bf1d5535ab6c649ce44b71d3665d8ba4b03f
Diffstat (limited to 'Android.mk')
-rw-r--r--Android.mk13
1 files changed, 13 insertions, 0 deletions
diff --git a/Android.mk b/Android.mk
new file mode 100644
index 00000000..7f33ad5e
--- /dev/null
+++ b/Android.mk
@@ -0,0 +1,13 @@
+LOCAL_PATH:= $(call my-dir)
+include $(CLEAR_VARS)
+
+LOCAL_MODULE_TAGS := optional
+
+LOCAL_SRC_FILES := $(call all-java-files-under, src)
+LOCAL_PACKAGE_NAME := TV
+
+# It is required for android.permission.ALL_EPG_DATA
+LOCAL_PRIVILEGED_MODULE := true
+
+include $(BUILD_PACKAGE)
+include $(call all-makefiles-under,$(LOCAL_PATH))