aboutsummaryrefslogtreecommitdiff
path: root/Android.mk
diff options
context:
space:
mode:
authorNick Chalko <nchalko@google.com>2015-08-03 15:39:56 -0700
committerNick Chalko <nchalko@google.com>2015-08-03 15:53:37 -0700
commit816a4be1a0f34f6a48877c8afd3dbbca19eac435 (patch)
tree4f18dda269764494942f5313acc93db4a35d47db /Android.mk
parent6edd2b09e5d16a29c703a5fcbd2e88c5cf5e55b7 (diff)
downloadTV-816a4be1a0f34f6a48877c8afd3dbbca19eac435.tar.gz
Migrate Live Channels App Src to AOSP branch
Bug: 21625152 Change-Id: I07e2830b27440556dc757e6340b4f77d1c0cbc66
Diffstat (limited to 'Android.mk')
-rw-r--r--Android.mk37
1 files changed, 33 insertions, 4 deletions
diff --git a/Android.mk b/Android.mk
index 5012f590..fbeea89b 100644
--- a/Android.mk
+++ b/Android.mk
@@ -1,3 +1,19 @@
+#
+# Copyright (C) 2015 The Android Open Source Project
+#
+# Licensed under the Apache License, Version 2.0 (the "License");
+# you may not use this file except in compliance with the License.
+# You may obtain a copy of the License at
+#
+# http://www.apache.org/licenses/LICENSE-2.0
+#
+# Unless required by applicable law or agreed to in writing, software
+# distributed under the License is distributed on an "AS IS" BASIS,
+# WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
+# See the License for the specific language governing permissions and
+# limitations under the License.
+#
+
LOCAL_PATH:= $(call my-dir)
include $(CLEAR_VARS)
@@ -6,19 +22,32 @@ LOCAL_MODULE_TAGS := optional
LOCAL_SRC_FILES := $(call all-java-files-under, src)
LOCAL_PACKAGE_NAME := TV
-# It is required for android.permission.ALL_EPG_DATA
+# It is required for com.android.providers.tv.permission.ALL_EPG_DATA
LOCAL_PRIVILEGED_MODULE := true
+LOCAL_SDK_VERSION := system_current
LOCAL_RESOURCE_DIR := \
- $(TOP)/frameworks/support/v17/leanback/res \
+ $(TOP)/prebuilts/sdk/current/support/v7/recyclerview/res \
+ $(TOP)/prebuilts/sdk/current/support/v17/leanback/res \
$(LOCAL_PATH)/res
LOCAL_STATIC_JAVA_LIBRARIES := \
+ android-support-annotations \
android-support-v4 \
+ android-support-v7-palette \
android-support-v7-recyclerview \
- android-support-v17-leanback
+ android-support-v17-leanback \
+ tv-common
+
+LOCAL_JAVACFLAGS := -Xlint:deprecation -Xlint:unchecked
-LOCAL_AAPT_FLAGS += --auto-add-overlay --extra-packages android.support.v17.leanback
+include $(LOCAL_PATH)/version.mk
+LOCAL_AAPT_FLAGS := --auto-add-overlay \
+ --extra-packages android.support.v7.recyclerview \
+ --extra-packages android.support.v17.leanback \
+ --version-name "$(version_name_package)" \
+ --version-code $(version_code_package) \
+LOCAL_PROGUARD_FLAG_FILES := proguard.flags
include $(BUILD_PACKAGE)
include $(call all-makefiles-under,$(LOCAL_PATH))