aboutsummaryrefslogtreecommitdiff
path: root/jni
diff options
context:
space:
mode:
authorNick Chalko <nchalko@google.com>2017-05-04 14:37:34 -0700
committerNick Chalko <nchalko@google.com>2017-05-05 06:18:44 -0700
commit3dfa929b24f38ac7836450176d88ceab41dc6ac5 (patch)
tree675a324760c582713e2e0080775ea17357f75b65 /jni
parentfddf3fd148c1fc94c48ee5684e47dbb56512e758 (diff)
downloadTV-3dfa929b24f38ac7836450176d88ceab41dc6ac5.tar.gz
Sync to ub-tv-dev at f0024d79653da8c8999a91f995431a645a6ff4a2
Change-Id: I4199ec04cacb4a78be58b85302a39d917658dc28
Diffstat (limited to 'jni')
-rw-r--r--jni/Android.mk20
1 files changed, 19 insertions, 1 deletions
diff --git a/jni/Android.mk b/jni/Android.mk
index 684830c9..9cb3d42e 100644
--- a/jni/Android.mk
+++ b/jni/Android.mk
@@ -1,12 +1,30 @@
+#
+# Copyright (C) 2017 The Android Open Source Project
+#
+# Licensed under the Apache License, Version 2.0 (the "License");
+# you may not use this file except in compliance with the License.
+# You may obtain a copy of the License at
+#
+# http://www.apache.org/licenses/LICENSE-2.0
+#
+# Unless required by applicable law or agreed to in writing, software
+# distributed under the License is distributed on an "AS IS" BASIS,
+# WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
+# See the License for the specific language governing permissions and
+# limitations under the License.
+#
+
LOCAL_PATH := $(call my-dir)
# --------------------------------------------------------------
include $(CLEAR_VARS)
-LOCAL_MODULE := libtunertvinput_jni
+LOCAL_MODULE := libtunertvinput_jni
LOCAL_SRC_FILES += tunertvinput_jni.cpp DvbManager.cpp
LOCAL_SDK_VERSION := 21
LOCAL_NDK_STL_VARIANT := stlport_static
LOCAL_LDLIBS := -llog
+
include $(BUILD_SHARED_LIBRARY)
+include $(call all-makefiles-under,$(LOCAL_PATH))