aboutsummaryrefslogtreecommitdiff
path: root/tests
diff options
context:
space:
mode:
authorYoungsang Cho <youngsang@google.com>2014-04-17 18:44:13 -0700
committerYoungsang Cho <youngsang@google.com>2014-04-22 13:58:14 -0700
commit3f07ce6c09b77e0c9224a16a4c73c8750ff8a07b (patch)
tree100ae34d8053c99d4831b6f21f0d54676044e150 /tests
parent12f0705c6a8093543fc33bc7e85070f6e13fbe6b (diff)
downloadTV-3f07ce6c09b77e0c9224a16a4c73c8750ff8a07b.tar.gz
Initial check-in of TV app
TV is an app playing TV based on TV input framework. The app has basic TV features : Channel up/down, input change, input name configuration, and so on. Change-Id: If9a3bf1d5535ab6c649ce44b71d3665d8ba4b03f
Diffstat (limited to 'tests')
-rw-r--r--tests/Android.mk15
-rw-r--r--tests/AndroidManifest.xml15
-rw-r--r--tests/src/com/android/tv/tests/TvActivityTest.java32
3 files changed, 62 insertions, 0 deletions
diff --git a/tests/Android.mk b/tests/Android.mk
new file mode 100644
index 00000000..cc2fff01
--- /dev/null
+++ b/tests/Android.mk
@@ -0,0 +1,15 @@
+LOCAL_PATH:= $(call my-dir)
+include $(CLEAR_VARS)
+
+LOCAL_MODULE_TAGS := tests
+
+LOCAL_JAVA_LIBRARIES := android.test.runner
+
+# Include all test java files.
+LOCAL_SRC_FILES := $(call all-java-files-under, src)
+
+LOCAL_PACKAGE_NAME := TVTests
+
+LOCAL_INSTRUMENTATION_FOR := TV
+
+include $(BUILD_PACKAGE)
diff --git a/tests/AndroidManifest.xml b/tests/AndroidManifest.xml
new file mode 100644
index 00000000..7c590925
--- /dev/null
+++ b/tests/AndroidManifest.xml
@@ -0,0 +1,15 @@
+<?xml version="1.0" encoding="utf-8"?>
+<manifest xmlns:android="http://schemas.android.com/apk/res/android"
+ package="com.android.tv.tests" >
+
+ <uses-sdk android:minSdkVersion="19" />
+
+ <instrumentation
+ android:name="android.test.InstrumentationTestRunner"
+ android:targetPackage="com.android.tv" />
+
+ <application android:label="TVTest" >
+ <uses-library android:name="android.test.runner" />
+ </application>
+
+</manifest> \ No newline at end of file
diff --git a/tests/src/com/android/tv/tests/TvActivityTest.java b/tests/src/com/android/tv/tests/TvActivityTest.java
new file mode 100644
index 00000000..4b918826
--- /dev/null
+++ b/tests/src/com/android/tv/tests/TvActivityTest.java
@@ -0,0 +1,32 @@
+/*
+ * Copyright (C) 2014 The Android Open Source Project
+ *
+ * Licensed under the Apache License, Version 2.0 (the "License");
+ * you may not use this file except in compliance with the License.
+ * You may obtain a copy of the License at
+ *
+ * http://www.apache.org/licenses/LICENSE-2.0
+ *
+ * Unless required by applicable law or agreed to in writing, software
+ * distributed under the License is distributed on an "AS IS" BASIS,
+ * WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
+ * See the License for the specific language governing permissions and
+ * limitations under the License.
+ */
+
+package com.android.tv.tests;
+
+import android.test.ActivityInstrumentationTestCase2;
+
+import com.android.tv.TvActivity;
+
+public class TvActivityTest extends ActivityInstrumentationTestCase2<TvActivity> {
+
+ public TvActivityTest() {
+ super(TvActivity.class);
+ }
+
+ public void testLifeCycle() {
+ getActivity();
+ }
+}