aboutsummaryrefslogtreecommitdiff
path: root/version.mk
diff options
context:
space:
mode:
authorNick Chalko <nchalko@google.com>2015-09-01 09:05:04 -0700
committerNick Chalko <nchalko@google.com>2015-09-16 06:46:50 -0700
commit07b043dc3db83d6d20f0e8513b946830ab00e37b (patch)
tree705ade719e5c2853c070fe40b8518a56ac37f6d0 /version.mk
parentb5429e4406a580953bbdac5817e421cf0ab7aae3 (diff)
downloadTV-07b043dc3db83d6d20f0e8513b946830ab00e37b.tar.gz
Sync to ub-tv-friends at 1.06.202
git hash 3c1965f5dcc60243f1fe600cb35f19bd5f01fc27 Change-Id: I90b77790f9074677ecef72a23235d2b33eacb76a
Diffstat (limited to 'version.mk')
-rw-r--r--version.mk11
1 files changed, 6 insertions, 5 deletions
diff --git a/version.mk b/version.mk
index 8772d4ea..a59ac3c5 100644
--- a/version.mk
+++ b/version.mk
@@ -18,7 +18,7 @@
# Cmmbbbtad
# where
# M - major version (one or more digits)
-# C - code major version (for legacy resons this is M+3)
+# C - code major version (for legacy reasons this is M+3)
# m - minor version (exactly 2)
# bbb - automatically specified build number (exactly 3 digits)
# t - build type (exactly 1 digit). Current valid values are:
@@ -48,9 +48,10 @@
base_version_major := 1
# Change this for each branch
-base_version_minor := 05
+base_version_minor := 06
# The date of the first commit checked in to the current branch
-base_version_since := 2015-05-21
+base_version_since := 2015-07-22
+
# code_version_major will overflow at 22
code_version_major := $(shell echo $$(($(base_version_major)+3)))
@@ -58,8 +59,8 @@ code_version_major := $(shell echo $$(($(base_version_major)+3)))
git_commit_count := $(shell git --git-dir $(LOCAL_PATH)/.git rev-list --since=$(base_version_since) --no-merges --count HEAD)
git_commit_count_usb := $(shell git --git-dir $(LOCAL_PATH)/../UsbTunerTvInput/.git rev-list --since=$(base_version_since) --no-merges --count HEAD)
#code_version_build := $(shell printf "%03d" $$(($(git_commit_count)+$(git_commit_count_usb))))
-# TODO http://b/22930520 version.mk sometimes goes backwards
-code_version_build := 570
+# TODO http://b/22930520 version.mk sometimes goes backwards
+code_version_build=202
#####################################################
#####################################################