aboutsummaryrefslogtreecommitdiff
path: root/version.mk
diff options
context:
space:
mode:
authorYoungsang Cho <youngsang@google.com>2016-05-11 01:20:46 +0000
committerYoungsang Cho <youngsang@google.com>2016-05-11 01:20:46 +0000
commit3a72b93e554bd22a5c64e71a6956d9604ce05108 (patch)
tree3d9a5451eb5ac85f8c18619c282eb82eb8fa2ddf /version.mk
parent369b6a409204a9b2a95f7ba575d7c3b7bdc94ab7 (diff)
downloadTV-3a72b93e554bd22a5c64e71a6956d9604ce05108.tar.gz
DO NOT MERGE Revert "DO NOT MERGE Sync to joey ub-tv-dev at e7fbaa585b1eb7afec05f05032d2e8d99fb595d4"
This reverts commit 369b6a409204a9b2a95f7ba575d7c3b7bdc94ab7. Change-Id: I9abfc39974fa42edcc1eb6b6ec2e53782b4fcf5f
Diffstat (limited to 'version.mk')
-rw-r--r--version.mk8
1 files changed, 6 insertions, 2 deletions
diff --git a/version.mk b/version.mk
index e0d8cd02..70f4ec4c 100644
--- a/version.mk
+++ b/version.mk
@@ -48,13 +48,17 @@
base_version_major := 1
# Change this for each branch
-base_version_minor := 10
+base_version_minor := 09
+# The date of the first commit checked in to the current branch
+base_version_since := 2015-11-21
# code_version_major will overflow at 22
code_version_major := $(shell echo $$(($(base_version_major)+3)))
+git_commit_count := $(shell git --git-dir $(LOCAL_PATH)/.git rev-list --since=$(base_version_since) --all --count HEAD)
# x86 and arm sometimes don't match.
-code_version_build := 596
+#code_version_build := $(shell printf "%03d" $(git_commit_count))
+code_version_build := 420
#####################################################
#####################################################
# Collect automatic version code parameters