aboutsummaryrefslogtreecommitdiff
path: root/version.mk
diff options
context:
space:
mode:
authorDan Willemsen <dwillemsen@google.com>2016-09-17 01:20:35 +0000
committerandroid-build-merger <android-build-merger@google.com>2016-09-17 01:20:35 +0000
commit785c32f8a2d049c2f03e7bd51e0965d3cfe14109 (patch)
tree1be45747d7e2142c3c3929d95301a22dc8ae52cf /version.mk
parent3c1e7ad3818883ec1864261a1797fbad594e7803 (diff)
parent7bdf9eb64d445eb8b7a95fbb0d86da6313a9ed68 (diff)
downloadTV-785c32f8a2d049c2f03e7bd51e0965d3cfe14109.tar.gz
Don't add BUILD_NUMBER to version for platform builds am: 04bf2c2a3e am: cfaee0edf0 am: b15401fe28
am: 7bdf9eb64d Change-Id: Ib0ed96dddba088df2f5b020f09b4b3d36914fbb6
Diffstat (limited to 'version.mk')
-rw-r--r--version.mk5
1 files changed, 5 insertions, 0 deletions
diff --git a/version.mk b/version.mk
index a8165426..026f2aae 100644
--- a/version.mk
+++ b/version.mk
@@ -87,11 +87,13 @@ base_version_density := 0
version_code_package := $(code_version_major)$(base_version_minor)$(code_version_build)$(base_version_buildtype)$(base_version_arch)$(base_version_density)
# The version name scheme for the package apk is:
+# - For platform builds: M.mm.bbb
# - For eng build (t=0): M.mm.bbb eng.$(USER)-hh-date-ad
# - For build server (t=1): M.mm.bbb (nnnnnn-ad)
# where nnnnnn is the build number from the build server (no zero-padding)
# and hh is the git hash
# On eng builds, the BUILD_NUMBER has the user and timestamp inline
+ifdef TARGET_BUILD_APPS
ifneq "" "$(filter eng.%,$(BUILD_NUMBER))"
git_hash := $(shell git --git-dir $(LOCAL_PATH)/.git log -n 1 --pretty=format:%h)
date_string := $(shell date +%m%d%y_%H%M%S)
@@ -99,6 +101,9 @@ ifneq "" "$(filter eng.%,$(BUILD_NUMBER))"
else
version_name_package := $(base_version_major).$(base_version_minor).$(code_version_build) ($(BUILD_NUMBER)-$(base_version_arch)$(base_version_density))
endif
+else # !TARGET_BUILD_APPS
+ version_name_package := $(base_version_major).$(base_version_minor).$(code_version_build)
+endif
# Cleanup the locals
code_version_major :=