aboutsummaryrefslogtreecommitdiff
path: root/version.mk
diff options
context:
space:
mode:
authorNick Chalko <nchalko@google.com>2017-10-03 10:16:37 -0700
committerXin Li <delphij@google.com>2017-10-31 15:39:46 -0700
commit9c40502f7d92098bdec63031af5dca87ead8d405 (patch)
treed31e2adc1f9cce4f27ca07d30bee921032e33a3c /version.mk
parent8240a88ba4469279d99444bcd08eebdc1c0dc5d8 (diff)
downloadTV-9c40502f7d92098bdec63031af5dca87ead8d405.tar.gz
Sync to match Live Channels 1.15(ncis)
aka ub-tv-dev at a73a150bb7d0d1ce867ef980c6ac8411899d40ad Test: build with support-27.0-dev branch merge Bug: 68345297 Bug: 64021596 Change-Id: I7c544fd15e2c58784f8babc31877ad0dfeebb4c0 (cherry picked from commit 633eb826b8c97731dfc5ef12c7bf78a63734275d)
Diffstat (limited to 'version.mk')
-rw-r--r--version.mk6
1 files changed, 3 insertions, 3 deletions
diff --git a/version.mk b/version.mk
index f63f5834..6886dc07 100644
--- a/version.mk
+++ b/version.mk
@@ -48,13 +48,13 @@
base_version_major := 1
# Change this for each branch
-base_version_minor := 11
+base_version_minor := 15
# code_version_major will overflow at 22
code_version_major := $(shell echo $$(($(base_version_major)+3)))
# x86 and arm sometimes don't match.
-code_version_build := 011
+code_version_build := 007
#####################################################
#####################################################
# Collect automatic version code parameters
@@ -96,7 +96,7 @@ version_code_package := $(code_version_major)$(base_version_minor)$(code_version
ifdef TARGET_BUILD_APPS
ifneq "" "$(filter eng.%,$(BUILD_NUMBER))"
git_hash := $(shell git --git-dir $(LOCAL_PATH)/.git log -n 1 --pretty=format:%h)
- date_string := $(shell date +%m%d%y_%H%M%S)
+ date_string := $(shell date +%Y-%m-%d)
version_name_package := $(base_version_major).$(base_version_minor).$(code_version_build) (eng.$(USER).$(git_hash).$(date_string)-$(base_version_arch)$(base_version_density))
else
version_name_package := $(base_version_major).$(base_version_minor).$(code_version_build) ($(BUILD_NUMBER)-$(base_version_arch)$(base_version_density))