aboutsummaryrefslogtreecommitdiff
path: root/tests/common/Android.mk
diff options
context:
space:
mode:
Diffstat (limited to 'tests/common/Android.mk')
-rw-r--r--tests/common/Android.mk4
1 files changed, 3 insertions, 1 deletions
diff --git a/tests/common/Android.mk b/tests/common/Android.mk
index f8263311..62005890 100644
--- a/tests/common/Android.mk
+++ b/tests/common/Android.mk
@@ -9,9 +9,11 @@ LOCAL_SRC_FILES := \
LOCAL_STATIC_JAVA_LIBRARIES := \
android-support-annotations \
mockito-target \
- tv-common \
ub-uiautomator
+# Link tv-common as shared library to avoid the problem of initialization of the constants
+LOCAL_JAVA_LIBRARIES := tv-common
+
LOCAL_INSTRUMENTATION_FOR := TV
LOCAL_MODULE := tv-test-common
LOCAL_MODULE_TAGS := optional