aboutsummaryrefslogtreecommitdiff
path: root/tuner/tests/testing/Android.mk
diff options
context:
space:
mode:
Diffstat (limited to 'tuner/tests/testing/Android.mk')
-rw-r--r--tuner/tests/testing/Android.mk29
1 files changed, 29 insertions, 0 deletions
diff --git a/tuner/tests/testing/Android.mk b/tuner/tests/testing/Android.mk
new file mode 100644
index 00000000..0d71b739
--- /dev/null
+++ b/tuner/tests/testing/Android.mk
@@ -0,0 +1,29 @@
+LOCAL_PATH:= $(call my-dir)
+include $(CLEAR_VARS)
+
+# Include all test java files.
+LOCAL_SRC_FILES := \
+ $(call all-java-files-under, src) \
+ $(call all-Iaidl-files-under, src)
+
+LOCAL_STATIC_JAVA_LIBRARIES := \
+ android-support-annotations \
+ android-support-test \
+ guava \
+ mockito-target \
+ platform-robolectric-3.6.1-prebuilt \
+ truth-0-36-prebuilt-jar \
+ ub-uiautomator \
+
+# Link tv-common as shared library to avoid the problem of initialization of the constants
+LOCAL_JAVA_LIBRARIES := tv-common
+
+LOCAL_INSTRUMENTATION_FOR := LiveTv
+LOCAL_MODULE := tv-tuner-testing
+LOCAL_MODULE_TAGS := optional
+LOCAL_SDK_VERSION := system_current
+
+LOCAL_RESOURCE_DIR := $(LOCAL_PATH)/res
+LOCAL_AIDL_INCLUDES += $(LOCAL_PATH)/src
+
+include $(BUILD_STATIC_JAVA_LIBRARY)