summaryrefslogtreecommitdiff
path: root/jni/Android.mk
diff options
context:
space:
mode:
authorJeff Sharkey <jsharkey@android.com>2013-04-14 16:16:49 -0700
committerJeff Sharkey <jsharkey@android.com>2013-04-25 09:59:52 -0700
commit00b00812cd0c883c2380065d7fda29512d5477f0 (patch)
treee46d54ccffbcae9ca81736263e00c6381d7c8207 /jni/Android.mk
parenta816285f9c02e687268e76f02896ada33398b0dd (diff)
downloadTerminal-00b00812cd0c883c2380065d7fda29512d5477f0.tar.gz
Add scrollback support.
Switch terminal rendering to use ListView, splitting each row into a TerminalLineView item. This leverages existing ListView display list optimizations when scrolling, and gives us fling and overscroll for free. However, the simple case of a single line scrolling requires an entire screen rebind. Added locking between I/O thread and UI thread to provide consistent view of terminal state. Snap to current upstream libvterm, which has updated scrollback API. Examine full cell style when building runs. Address terminals using "keys" instead of indicies, since ordering can shift. Save and restore instance state to remember scrollback position. Avoid crashing after closing last terminal. Remove unused callbacks. Bug: 8332387 Change-Id: I06468d16ae8e1ff8ac79b7115c7cb3f9434b3c0d
Diffstat (limited to 'jni/Android.mk')
-rw-r--r--jni/Android.mk9
1 files changed, 6 insertions, 3 deletions
diff --git a/jni/Android.mk b/jni/Android.mk
index fb4721a..1be6426 100644
--- a/jni/Android.mk
+++ b/jni/Android.mk
@@ -9,12 +9,15 @@ LOCAL_SRC_FILES := \
LOCAL_C_INCLUDES += \
external/libvterm/include \
- libcore/include
+ libcore/include \
+ frameworks/base/include
LOCAL_SHARED_LIBRARIES := \
+ libandroidfw \
+ libandroid_runtime \
liblog \
- libutils \
- libnativehelper
+ libnativehelper \
+ libutils
LOCAL_STATIC_LIBRARIES := \
libvterm