summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--Android.mk9
1 files changed, 8 insertions, 1 deletions
diff --git a/Android.mk b/Android.mk
index b0ba92c..6144db7 100644
--- a/Android.mk
+++ b/Android.mk
@@ -7,7 +7,14 @@ LOCAL_SRC_FILES := $(call all-subdir-java-files)
LOCAL_STATIC_JAVA_LIBRARIES := android-support-v4
-LOCAL_JNI_SHARED_LIBRARIES := libjni_terminal
+# If this is an unbundled build (to install seprately) then include
+# the libraries in the APK, otherwise just put them in /system/lib and
+# leave them out of the APK
+ifneq (,$(TARGET_BUILD_APPS))
+ LOCAL_JNI_SHARED_LIBRARIES := libjni_terminal
+else
+ LOCAL_REQUIRED_MODULES := libjni_terminal
+endif
# TODO: enable proguard once development has settled down
#LOCAL_PROGUARD_FLAG_FILES := proguard.flags