summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJakub Pawlowski <jpawlowski@google.com>2017-07-05 15:29:48 -0700
committerJakub Pawlowski <jpawlowski@google.com>2017-07-06 22:41:32 +0000
commit79ccd3543999c1cc8ea211ea54384a9096b693a9 (patch)
tree7dffa50f14441ca3fef03ffad0ca52fa58ba1bf3
parent0fba4364b09c47766046e5afb12fd3304273323f (diff)
downloadconnectivity-79ccd3543999c1cc8ea211ea54384a9096b693a9.tar.gz
Make RawAddress into a class (6/6)android-o-preview-4
* Add libbluetooth-types - library containing types implementation, that is common between stystem/bt and packages/apps/Bluetooth. It must be included in every project using btif interface. * Put Raw Address implementation into libbluetooth-types * Unify all "to/from string" helper methods into ToString and FromString * bd_addr_empty -> RawAddress::kEmpty * bd_addr_any -> RawAddress::kAny Also fix leaks in jni str2addr by adding ReleaseStringUTFChars Test: types_unittest Change-Id: I1eccec62cfb764f5add22ab9dd3b3e88bfd05a97 Merged-In: I1eccec62cfb764f5add22ab9dd3b3e88bfd05a97
-rw-r--r--sl4n/Android.mk1
1 files changed, 1 insertions, 0 deletions
diff --git a/sl4n/Android.mk b/sl4n/Android.mk
index cb69dab..43c93ea 100644
--- a/sl4n/Android.mk
+++ b/sl4n/Android.mk
@@ -43,6 +43,7 @@ LOCAL_SHARED_LIBRARIES += \
liblog
LOCAL_STATIC_LIBRARIES += \
+ libbluetooth-types \
libbtcore \
libosi \
libbluetooth-binder-common