summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBob Badour <bbadour@google.com>2021-02-19 02:25:32 +0000
committerAutomerger Merge Worker <android-build-automerger-merge-worker@system.gserviceaccount.com>2021-02-19 02:25:32 +0000
commit28877c404ed75cea0bc46f8d0a3ebc75cd57675d (patch)
tree610be6a2dfcd8bea6abed95268b5520317622beb
parenta8c9556a58368bf00995641eafdaff8c18ed8621 (diff)
parenta76d790777fe8d36266d20d5f25758fa05213325 (diff)
downloadTimeZoneData-28877c404ed75cea0bc46f8d0a3ebc75cd57675d.tar.gz
[LSC] Add LOCAL_LICENSE_KINDS to packages/apps/TimeZoneData am: 5eb6850f7d am: a76d790777
Original change: https://android-review.googlesource.com/c/platform/packages/apps/TimeZoneData/+/1588407 MUST ONLY BE SUBMITTED BY AUTOMERGER Change-Id: Ieca09bd61699d2123eebf6ddcb11bbd2ea5d70b2
-rw-r--r--Android.bp4
-rw-r--r--oem_template/data_app_prebuilt/include_app_prebuilt.mk2
-rw-r--r--oem_template/xts/Android.mk2
-rw-r--r--testing/xts/Android.bp4
4 files changed, 12 insertions, 0 deletions
diff --git a/Android.bp b/Android.bp
index fc5a8a9..0ac28da 100644
--- a/Android.bp
+++ b/Android.bp
@@ -13,6 +13,10 @@
// limitations under the License.
// A static library containing all the source needed by a Time Zone Data app.
+package {
+ default_applicable_licenses: ["Android-Apache-2.0"],
+}
+
java_library {
name: "time_zone_distro_provider",
diff --git a/oem_template/data_app_prebuilt/include_app_prebuilt.mk b/oem_template/data_app_prebuilt/include_app_prebuilt.mk
index 3ebc464..ec9939a 100644
--- a/oem_template/data_app_prebuilt/include_app_prebuilt.mk
+++ b/oem_template/data_app_prebuilt/include_app_prebuilt.mk
@@ -22,6 +22,8 @@
#
LOCAL_MODULE := TimeZoneDataPrebuilt$(TIME_ZONE_DATA_APP_SUFFIX)
+LOCAL_LICENSE_KINDS := SPDX-license-identifier-Apache-2.0
+LOCAL_LICENSE_CONDITIONS := notice
LOCAL_SRC_FILES := TimeZoneData$(TIME_ZONE_DATA_APP_SUFFIX).apk
LOCAL_OVERRIDES_PACKAGES := TimeZoneData$(TIME_ZONE_DATA_APP_SUFFIX)
LOCAL_MODULE_TAGS := optional
diff --git a/oem_template/xts/Android.mk b/oem_template/xts/Android.mk
index 25be082..d5ceeeb 100644
--- a/oem_template/xts/Android.mk
+++ b/oem_template/xts/Android.mk
@@ -23,6 +23,8 @@ LOCAL_COMPATIBILITY_SUITE := xts
# OEM-INSTRUCTION: OEMs should change this
LOCAL_MODULE := XtsTimeZoneTestCases
+LOCAL_LICENSE_KINDS := SPDX-license-identifier-Apache-2.0
+LOCAL_LICENSE_CONDITIONS := notice
LOCAL_STATIC_JAVA_LIBRARIES := time_zone_data_app_testing
diff --git a/testing/xts/Android.bp b/testing/xts/Android.bp
index 538595b..735a1c5 100644
--- a/testing/xts/Android.bp
+++ b/testing/xts/Android.bp
@@ -16,6 +16,10 @@
// OEMs can include this as a "_STATIC_" dependency and anything else needed to integrate with their
// own test suite. At runtime the libs below (or a superset) must be present.
+package {
+ default_applicable_licenses: ["Android-Apache-2.0"],
+}
+
java_library_host {
name: "time_zone_data_app_testing",
srcs: ["src/**/*.java"],