summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNeil Fuller <nfuller@google.com>2018-04-11 15:41:48 +0100
committerNeil Fuller <nfuller@google.com>2018-04-11 15:41:48 +0100
commit76563955917a8643d1c8911702560164cbbea1ad (patch)
tree59325acbf83aed12efc626772870e8dbdc3b45ad
parent82634f4ba67bdd62bfd0dc6d2e2dab63608971cf (diff)
downloadTimeZoneData-76563955917a8643d1c8911702560164cbbea1ad.tar.gz
Correct the app build for TimeZoneData
TimeZoneData is intended to be a prebuilt so it does not need to be installed. This change modifies the build rules to ensure the apk won't be generated in the system image. Test: Tested with the reference app Change-Id: I1e26990bfb43066d2c62aebf59114bb8594b8d76
-rw-r--r--oem_template/data_app/build_oem_data_app.mk5
1 files changed, 4 insertions, 1 deletions
diff --git a/oem_template/data_app/build_oem_data_app.mk b/oem_template/data_app/build_oem_data_app.mk
index f31e5d1..672a2cf 100644
--- a/oem_template/data_app/build_oem_data_app.mk
+++ b/oem_template/data_app/build_oem_data_app.mk
@@ -44,7 +44,10 @@ LOCAL_AAPT_FLAGS := --version-code $(TIME_ZONE_DATA_APP_VERSION_CODE) \
# OEM-INSTRUCTION: Modify the name, s/oemcorp/<Your company name>/
LOCAL_MODULE_OWNER := oemcorp
-LOCAL_PRIVILEGED_MODULE := true
+
+# The app build is expected to generate a prebuilt, so do not place the app in
+# the system image.
+LOCAL_UNINSTALLABLE_MODULE := true
# OEM-INSTRUCTION: Configure your own certificate.
LOCAL_CERTIFICATE :=