summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorXin Li <delphij@google.com>2017-11-02 12:14:50 -0700
committerXin Li <delphij@google.com>2017-11-02 12:14:50 -0700
commit3c11dd99cf8dd5e931e42e7a8068cd27e5e651f2 (patch)
treeb937e3a4d97bbd95aacaddaa5b2fbeddad5ef642
parent157e6ac39742fb5513660e3340fc03ac0196b39a (diff)
parent587cdcfbad39f38bdd25c267eeae01202a52f29d (diff)
downloadTimeZoneData-3c11dd99cf8dd5e931e42e7a8068cd27e5e651f2.tar.gz
Merge commit '587cdcfbad39f38bdd25c267eeae01202a52f29d' from
oc-mr1-dev-plus-aosp-without-vendor into stage-aosp-master Change-Id: I89320e7eb1150de3a1f95fd5cf246f3db6cb83d7
-rw-r--r--Android.mk3
-rw-r--r--src/main/com/android/timezone/data/TimeZoneRulesDataProvider.java4
2 files changed, 4 insertions, 3 deletions
diff --git a/Android.mk b/Android.mk
index 36401e6..ba2a1cb 100644
--- a/Android.mk
+++ b/Android.mk
@@ -22,7 +22,8 @@ LOCAL_MODULE := time_zone_distro_provider
LOCAL_MODULE_TAGS := optional
LOCAL_SRC_FILES := $(call all-java-files-under, src/main)
LOCAL_PROGUARD_FLAG_FILES := $(LOCAL_PATH)/proguard.cfg
-LOCAL_STATIC_JAVA_LIBRARIES := time_zone_distro
+LOCAL_STATIC_JAVA_LIBRARIES := time_zone_distro_unbundled android-support-annotations
+LOCAL_SDK_VERSION := system_current
include $(BUILD_STATIC_JAVA_LIBRARY)
include $(call all-makefiles-under,$(LOCAL_PATH))
diff --git a/src/main/com/android/timezone/data/TimeZoneRulesDataProvider.java b/src/main/com/android/timezone/data/TimeZoneRulesDataProvider.java
index 23d9481..d92665a 100644
--- a/src/main/com/android/timezone/data/TimeZoneRulesDataProvider.java
+++ b/src/main/com/android/timezone/data/TimeZoneRulesDataProvider.java
@@ -20,8 +20,6 @@ import com.android.timezone.distro.DistroException;
import com.android.timezone.distro.DistroVersion;
import com.android.timezone.distro.TimeZoneDistro;
-import android.annotation.NonNull;
-import android.annotation.Nullable;
import android.content.ContentProvider;
import android.content.ContentValues;
import android.content.Context;
@@ -36,6 +34,8 @@ import android.os.ParcelFileDescriptor;
import android.os.UserHandle;
import android.provider.TimeZoneRulesDataContract;
import android.provider.TimeZoneRulesDataContract.Operation;
+import android.support.annotation.NonNull;
+import android.support.annotation.Nullable;
import java.io.File;
import java.io.FileNotFoundException;