summaryrefslogtreecommitdiff
path: root/oem_template/data_app/build_oem_data_app.mk
diff options
context:
space:
mode:
authorNeil Fuller <nfuller@google.com>2017-09-27 09:22:24 +0100
committerNeil Fuller <nfuller@google.com>2017-09-27 13:49:45 +0000
commit9e06a0a119e710e043e5f1c376429afec52c01d3 (patch)
treee48ae03de13332537041a254a3471bce5044e78d /oem_template/data_app/build_oem_data_app.mk
parent21843e19927764b3210e504345738e7fa2321565 (diff)
downloadTimeZoneData-9e06a0a119e710e043e5f1c376429afec52c01d3.tar.gz
Update the template files provided for partners
Update the template files provided for partners to use when integrating the time zone update feature. The manifests/ directory is no longer used: OEMs have to customize the AndroidManifest.xml because not everything can be handled via aapt. Bug: 65165603 Test: None, documentation only. None of the files are included in the build Change-Id: I742cb1eebcf2f2e2b6924447916442c83f62a52e
Diffstat (limited to 'oem_template/data_app/build_oem_data_app.mk')
-rw-r--r--oem_template/data_app/build_oem_data_app.mk15
1 files changed, 6 insertions, 9 deletions
diff --git a/oem_template/data_app/build_oem_data_app.mk b/oem_template/data_app/build_oem_data_app.mk
index 7d9e611..f31e5d1 100644
--- a/oem_template/data_app/build_oem_data_app.mk
+++ b/oem_template/data_app/build_oem_data_app.mk
@@ -32,16 +32,15 @@ LOCAL_STATIC_JAVA_LIBRARIES := time_zone_distro_provider
# All resources come from the vendor-specific dirs.
LOCAL_RESOURCE_DIR := $(OEM_APP_PATH)/res
-LOCAL_FULL_MANIFEST_FILE := packages/apps/TimeZoneData/manifests/install/AndroidManifest.xml
+# Ensure the app can be unbundled by only depending on System APIs.
+LOCAL_SDK_VERSION := system_current
+
+LOCAL_FULL_MANIFEST_FILE := $(OEM_APP_PATH)/AndroidManifest.xml
LOCAL_PACKAGE_NAME := TimeZoneData$(TIME_ZONE_DATA_APP_SUFFIX)
LOCAL_AAPT_FLAGS := --version-code $(TIME_ZONE_DATA_APP_VERSION_CODE) \
- --version-name $(TIME_ZONE_DATA_APP_VERSION_NAME) \
- --min-sdk-version $(PLATFORM_SDK_VERSION)
-
-# OEM-INSTRUCTION: Modify the name, s/oemcorp/<Your company name>/
-LOCAL_AAPT_FLAGS += --rename-manifest-package com.oemcorp.android.timezone.data
+ --version-name $(TIME_ZONE_DATA_APP_VERSION_NAME)
# OEM-INSTRUCTION: Modify the name, s/oemcorp/<Your company name>/
LOCAL_MODULE_OWNER := oemcorp
@@ -50,6 +49,4 @@ LOCAL_PRIVILEGED_MODULE := true
# OEM-INSTRUCTION: Configure your own certificate.
LOCAL_CERTIFICATE :=
-# If LOCAL_COMPATIBILITY_SUITE is unset this is the same as BUILD_PACKAGE so
-# can be used for building test or production packages.
-include $(BUILD_CTS_PACKAGE)
+include $(BUILD_PACKAGE)