summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnton Hansson <hansson@google.com>2018-02-22 17:03:01 +0000
committerAnton Hansson <hansson@google.com>2018-02-22 17:03:04 +0000
commitcb62ec134f8c779b17d13dd6c2dbe3b44219b460 (patch)
tree3541dc0f76a2252022c949f3a44e9881f95935ec
parent1c91b7d5be075cb336a3401af7a81cf825ff924d (diff)
downloadTimeZoneUpdater-cb62ec134f8c779b17d13dd6c2dbe3b44219b460.tar.gz
This change sets LOCAL_SDK_VERSION for all packages where this is possible without breaking the build, and LOCAL_PRIVATE_PLATFORM_APIS := true otherwise. Setting one of these two will be made required soon, and this is a change in preparation for that. Not setting LOCAL_SDK_VERSION makes the app implicitly depend on the bootclasspath, which is often not required. This change effectively makes depending on private apis opt-in rather than opt-out. Test: make relevant packages Bug: 73535841 Change-Id: I283419238eddc3a623e8ca53a8a717d90740b573
-rw-r--r--Android.mk1
1 files changed, 1 insertions, 0 deletions
diff --git a/Android.mk b/Android.mk
index 08e0e86..fcbc2bd 100644
--- a/Android.mk
+++ b/Android.mk
@@ -29,6 +29,7 @@ LOCAL_MODULE_TAGS := optional
LOCAL_PROGUARD_ENABLED := disabled
LOCAL_STATIC_JAVA_LIBRARIES := time_zone_updater
LOCAL_PACKAGE_NAME := TimeZoneUpdater
+LOCAL_PRIVATE_PLATFORM_APIS := true
LOCAL_CERTIFICATE := platform
LOCAL_PRIVILEGED_MODULE := true
include $(BUILD_PACKAGE)