summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSasha Smundak <asmundak@google.com>2019-01-15 18:12:31 -0800
committerandroid-build-merger <android-build-merger@google.com>2019-01-15 18:12:31 -0800
commitaf7367aac90f91a76468f4a9668d7f437d9884c7 (patch)
tree030fa1380d656416d3ff9f18e7f8eb818fd9c4b7
parent6d1a2ab92b83b2251f07d57e01b9059ff2de91fd (diff)
parent08d29a864c3f98253874b5faea674eb3b9a7aef8 (diff)
downloadTimeZoneUpdater-af7367aac90f91a76468f4a9668d7f437d9884c7.tar.gz
Convert Android.mk file to Android.bp
am: 08d29a864c Change-Id: I8e4de010bf137c5247bbe9d002fe5e0575f51569
-rw-r--r--Android.bp35
-rw-r--r--Android.mk36
2 files changed, 35 insertions, 36 deletions
diff --git a/Android.bp b/Android.bp
new file mode 100644
index 0000000..4a48145
--- /dev/null
+++ b/Android.bp
@@ -0,0 +1,35 @@
+// Copyright (C) 2017 The Android Open Source Project
+//
+// Licensed under the Apache License, Version 2.0 (the "License");
+// you may not use this file except in compliance with the License.
+// You may obtain a copy of the License at
+//
+// http://www.apache.org/licenses/LICENSE-2.0
+//
+// Unless required by applicable law or agreed to in writing, software
+// distributed under the License is distributed on an "AS IS" BASIS,
+// WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
+// See the License for the specific language governing permissions and
+// limitations under the License.
+
+// A static library containing all the source needed by the TimeZoneUpdater
+java_library {
+ name: "time_zone_updater",
+ srcs: [
+ "src/main/**/*.java",
+ "src/main/**/*.logtags", // Also include generated EventLogTags from the .logtags file.
+ ],
+ static_libs: ["time_zone_distro"],
+}
+
+android_app {
+ name: "TimeZoneUpdater",
+ optimize: {
+ enabled: false,
+ },
+ static_libs: ["time_zone_updater"],
+ platform_apis: true,
+ certificate: "platform",
+ privileged: true,
+ required: ["com.android.timezone.updater.xml"],
+}
diff --git a/Android.mk b/Android.mk
deleted file mode 100644
index 1dcd070..0000000
--- a/Android.mk
+++ /dev/null
@@ -1,36 +0,0 @@
-# Copyright (C) 2017 The Android Open Source Project
-#
-# Licensed under the Apache License, Version 2.0 (the "License");
-# you may not use this file except in compliance with the License.
-# You may obtain a copy of the License at
-#
-# http://www.apache.org/licenses/LICENSE-2.0
-#
-# Unless required by applicable law or agreed to in writing, software
-# distributed under the License is distributed on an "AS IS" BASIS,
-# WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
-# See the License for the specific language governing permissions and
-# limitations under the License.
-
-LOCAL_PATH:= $(call my-dir)
-
-# A static library containing all the source needed by the TimeZoneUpdater
-include $(CLEAR_VARS)
-LOCAL_MODULE_TAGS := optional
-LOCAL_MODULE := time_zone_updater
-LOCAL_SRC_FILES := $(call all-java-files-under, src/main)
-# Also include generated EventLogTags from the .logtags file.
-LOCAL_SRC_FILES += $(call all-logtags-files-under, src/main)
-LOCAL_STATIC_JAVA_LIBRARIES := time_zone_distro
-include $(BUILD_STATIC_JAVA_LIBRARY)
-
-include $(CLEAR_VARS)
-LOCAL_MODULE_TAGS := optional
-LOCAL_PROGUARD_ENABLED := disabled
-LOCAL_STATIC_JAVA_LIBRARIES := time_zone_updater
-LOCAL_PACKAGE_NAME := TimeZoneUpdater
-LOCAL_PRIVATE_PLATFORM_APIS := true
-LOCAL_CERTIFICATE := platform
-LOCAL_PRIVILEGED_MODULE := true
-LOCAL_REQUIRED_MODULES := com.android.timezone.updater.xml
-include $(BUILD_PACKAGE)