summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPaul Duffin <paulduffin@google.com>2017-01-17 14:49:42 +0000
committerPaul Duffin <paulduffin@google.com>2017-01-17 14:49:42 +0000
commitf11bb9b37f0a051099ffccc2278d7e6b303339ac (patch)
tree906a645bfb296bb08df5af3f26598b8e2b047047
parent7d3754cb8144935ca8a9a1f879cc29076c4f642e (diff)
downloadUnifiedEmail-f11bb9b37f0a051099ffccc2278d7e6b303339ac.tar.gz
Prepare for removal of legacy-test from default targets
In preparation for removing junit classes from the Android API the legacy-test target will be removed from the TARGET_DEFAULT_JAVA_LIBRARIES. This change adds explicit dependencies on junit and/or legacy-android-test to ensure that modules will compile properly once it is removed. Bug: 30188076 Test: make checkbuild Change-Id: I53f5e21f10ad862fe847389884c8107ff260a53e
-rw-r--r--tests/Android.mk2
1 files changed, 1 insertions, 1 deletions
diff --git a/tests/Android.mk b/tests/Android.mk
index 902d31f95..4762862b0 100644
--- a/tests/Android.mk
+++ b/tests/Android.mk
@@ -31,7 +31,7 @@ LOCAL_INSTRUMENTATION_FOR := UnifiedEmail
LOCAL_SRC_FILES := $(call all-java-files-under, $(src_dirs))
LOCAL_AAPT_FLAGS := --auto-add-overlay
-LOCAL_STATIC_JAVA_LIBRARIES := android-support-test
+LOCAL_STATIC_JAVA_LIBRARIES := android-support-test legacy-android-test
include $(BUILD_PACKAGE)