summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorYing Wang <wangying@google.com>2012-06-14 15:08:10 -0700
committerYing Wang <wangying@google.com>2012-06-15 21:03:35 -0700
commit3e0d206155efe1ecb1b5da9c7ed4a068ba07c8d9 (patch)
tree928db66412ab48a1de07cc47692acaf093c64eee
parent8f4d4e3be9391201544704434e6747f6db26c0d6 (diff)
downloadVoiceDialer-3e0d206155efe1ecb1b5da9c7ed4a068ba07c8d9.tar.gz
Bug: 6294985 Change-Id: Id361e65e535c7d4b5f373fc3a15144b8de56483a
-rw-r--r--Android.mk7
1 files changed, 7 insertions, 0 deletions
diff --git a/Android.mk b/Android.mk
index a9a231d..734f337 100644
--- a/Android.mk
+++ b/Android.mk
@@ -7,8 +7,15 @@ LOCAL_SRC_FILES := $(call all-java-files-under, src) \
LOCAL_PACKAGE_NAME := VoiceDialer
+LOCAL_REQUIRED_MODULES := libsrec_jni
include $(BUILD_PACKAGE)
+# Install the srec data files if VoiceDialer.apk is installed to system image.
+include external/srec/config/en.us/config.mk
+$(LOCAL_INSTALLED_MODULE) : | $(SREC_CONFIG_TARGET_FILES)
+# SREC_CONFIG_TARGET_FILES is from external/srec/config/en.us/config.mk and now can be cleaned up.
+SREC_CONFIG_TARGET_FILES :=
+
# Use the following include to make our test apk.
include $(call all-makefiles-under,$(LOCAL_PATH))