summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorYing Wang <wangying@google.com>2012-06-18 10:52:22 -0700
committerAndroid Git Automerger <android-git-automerger@android.com>2012-06-18 10:52:22 -0700
commiteebfc84a3c8baa6914ab48a1fe88db2efeb12ac1 (patch)
treeef982e45e1308ae3e12c66d303dd19de77b43edf
parent89b4742c5bbf6f47da69c22381af24ef3fdbfe32 (diff)
parent3e0d206155efe1ecb1b5da9c7ed4a068ba07c8d9 (diff)
downloadVoiceDialer-eebfc84a3c8baa6914ab48a1fe88db2efeb12ac1.tar.gz
am 3e0d2061: Let VoiceDialer.apk depend on libsrec_jni and srec data files.
* commit '3e0d206155efe1ecb1b5da9c7ed4a068ba07c8d9': Let VoiceDialer.apk depend on libsrec_jni and srec data files.
-rw-r--r--Android.mk7
1 files changed, 7 insertions, 0 deletions
diff --git a/Android.mk b/Android.mk
index a9a231d..734f337 100644
--- a/Android.mk
+++ b/Android.mk
@@ -7,8 +7,15 @@ LOCAL_SRC_FILES := $(call all-java-files-under, src) \
LOCAL_PACKAGE_NAME := VoiceDialer
+LOCAL_REQUIRED_MODULES := libsrec_jni
include $(BUILD_PACKAGE)
+# Install the srec data files if VoiceDialer.apk is installed to system image.
+include external/srec/config/en.us/config.mk
+$(LOCAL_INSTALLED_MODULE) : | $(SREC_CONFIG_TARGET_FILES)
+# SREC_CONFIG_TARGET_FILES is from external/srec/config/en.us/config.mk and now can be cleaned up.
+SREC_CONFIG_TARGET_FILES :=
+
# Use the following include to make our test apk.
include $(call all-makefiles-under,$(LOCAL_PATH))