summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--Android.mk7
1 files changed, 7 insertions, 0 deletions
diff --git a/Android.mk b/Android.mk
index a9a231d..734f337 100644
--- a/Android.mk
+++ b/Android.mk
@@ -7,8 +7,15 @@ LOCAL_SRC_FILES := $(call all-java-files-under, src) \
LOCAL_PACKAGE_NAME := VoiceDialer
+LOCAL_REQUIRED_MODULES := libsrec_jni
include $(BUILD_PACKAGE)
+# Install the srec data files if VoiceDialer.apk is installed to system image.
+include external/srec/config/en.us/config.mk
+$(LOCAL_INSTALLED_MODULE) : | $(SREC_CONFIG_TARGET_FILES)
+# SREC_CONFIG_TARGET_FILES is from external/srec/config/en.us/config.mk and now can be cleaned up.
+SREC_CONFIG_TARGET_FILES :=
+
# Use the following include to make our test apk.
include $(call all-makefiles-under,$(LOCAL_PATH))