summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSasha Smundak <asmundak@google.com>2019-01-09 16:15:11 -0800
committerSasha Smundak <asmundak@google.com>2019-01-09 16:15:11 -0800
commit3f665f8c48a4b41549b54cf5b97f7403e336ed18 (patch)
tree2f6332888766af6e6ebbecb7fbee3751c8417d46
parentf147ac2fdb2018353bd9d21ca4e69e441a53c6a1 (diff)
downloadWallpaperPicker-3f665f8c48a4b41549b54cf5b97f7403e336ed18.tar.gz
Convert Android.mk file to Android.bp
See build/soong/README.md for more information. Change-Id: I8feaf8b0db5e886c714c5cdfca8987a7e4978670 Fixes: 122333499 Test: treehugger
-rw-r--r--Android.bp35
-rw-r--r--Android.mk39
2 files changed, 35 insertions, 39 deletions
diff --git a/Android.bp b/Android.bp
new file mode 100644
index 0000000..abea11a
--- /dev/null
+++ b/Android.bp
@@ -0,0 +1,35 @@
+//
+// Copyright (C) 2016 The Android Open Source Project
+//
+// Licensed under the Apache License, Version 2.0 (the "License");
+// you may not use this file except in compliance with the License.
+// You may obtain a copy of the License at
+//
+// http://www.apache.org/licenses/LICENSE-2.0
+//
+// Unless required by applicable law or agreed to in writing, software
+// distributed under the License is distributed on an "AS IS" BASIS,
+// WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
+// See the License for the specific language governing permissions and
+// limitations under the License.
+//
+
+// Standalone Wallpaper picker app
+// ========================================================
+android_app {
+ name: "WallpaperPicker",
+ static_libs: ["android-support-v4"],
+ srcs: ["src/**/*.java"],
+ resource_dirs: ["res"],
+ sdk_version: "current",
+}
+
+// Static library for target
+// ========================================================
+android_library {
+ name: "libWallpaperPicker",
+ resource_dirs: ["res"],
+ sdk_version: "current",
+ srcs: ["src/**/*.java"],
+ libs: ["android-support-v4"],
+}
diff --git a/Android.mk b/Android.mk
deleted file mode 100644
index cc97679..0000000
--- a/Android.mk
+++ /dev/null
@@ -1,39 +0,0 @@
-#
-# Copyright (C) 2016 The Android Open Source Project
-#
-# Licensed under the Apache License, Version 2.0 (the "License");
-# you may not use this file except in compliance with the License.
-# You may obtain a copy of the License at
-#
-# http://www.apache.org/licenses/LICENSE-2.0
-#
-# Unless required by applicable law or agreed to in writing, software
-# distributed under the License is distributed on an "AS IS" BASIS,
-# WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
-# See the License for the specific language governing permissions and
-# limitations under the License.
-#
-
-LOCAL_PATH := $(call my-dir)
-
-# Standalone Wallpaper picker app
-# ========================================================
-include $(CLEAR_VARS)
-LOCAL_MODULE_TAGS := optional
-LOCAL_STATIC_JAVA_LIBRARIES := android-support-v4
-LOCAL_SRC_FILES := $(call all-java-files-under, src)
-LOCAL_RESOURCE_DIR := $(LOCAL_PATH)/res
-LOCAL_SDK_VERSION := current
-LOCAL_PACKAGE_NAME := WallpaperPicker
-include $(BUILD_PACKAGE)
-
-
-# Static library for target
-# ========================================================
-include $(CLEAR_VARS)
-LOCAL_MODULE := libWallpaperPicker
-LOCAL_RESOURCE_DIR := $(LOCAL_PATH)/res
-LOCAL_SDK_VERSION := current
-LOCAL_SRC_FILES := $(call all-java-files-under,src)
-LOCAL_JAVA_LIBRARIES := android-support-v4
-include $(BUILD_STATIC_JAVA_LIBRARY)