aboutsummaryrefslogtreecommitdiff
path: root/NotificationListenerSample/Android.mk
diff options
context:
space:
mode:
authorChris Wren <cwren@android.com>2014-05-07 17:44:21 -0400
committerQiwen Zhao <zhao@google.com>2014-05-28 07:35:23 -0700
commitf715fd998b172c4e8658715a26a41c69144380be (patch)
tree03fd268c9f813c49a9aff719212c91fe1b42775b /NotificationListenerSample/Android.mk
parente008f2f02529be466b91a8456ea736a48e3f13e4 (diff)
downloadexperimental-f715fd998b172c4e8658715a26a41c69144380be.tar.gz
example notification listener
demonstrate order-sensitive features of the listeners also launch contentIntents and handle dismissal Change-Id: I9e58c72a8d570f4b9a23e4642632b19fcd682dca Depends-On: I7244c65944a9657df41fb313b3cb5a52e149709d
Diffstat (limited to 'NotificationListenerSample/Android.mk')
-rw-r--r--NotificationListenerSample/Android.mk33
1 files changed, 33 insertions, 0 deletions
diff --git a/NotificationListenerSample/Android.mk b/NotificationListenerSample/Android.mk
new file mode 100644
index 0000000..5075a96
--- /dev/null
+++ b/NotificationListenerSample/Android.mk
@@ -0,0 +1,33 @@
+#
+# Copyright (C) 2014 The Android Open Source Project
+#
+# Licensed under the Apache License, Version 2.0 (the "License");
+# you may not use this file except in compliance with the License.
+# You may obtain a copy of the License at
+#
+# http://www.apache.org/licenses/LICENSE-2.0
+#
+# Unless required by applicable law or agreed to in writing, software
+# distributed under the License is distributed on an "AS IS" BASIS,
+# WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
+# See the License for the specific language governing permissions and
+# limitations under the License.
+#
+
+LOCAL_PATH:= $(call my-dir)
+
+include $(CLEAR_VARS)
+
+LOCAL_MODULE_TAGS := optional
+
+LOCAL_AAPT_FLAGS += -c mdpi,hdpi,xhdpi
+
+LOCAL_SRC_FILES := $(call all-java-files-under, src)
+
+LOCAL_STATIC_JAVA_LIBRARIES := android-support-v4
+
+LOCAL_PACKAGE_NAME := NotificationListenerSample
+LOCAL_CERTIFICATE := platform
+include $(BUILD_PACKAGE)
+
+include $(call all-makefiles-under,$(LOCAL_PATH))