aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaisuke Miyakawa <>2009-03-27 19:37:48 -0700
committerThe Android Open Source Project <initial-contribution@android.com>2009-03-27 19:37:48 -0700
commit73ba3a62d674e23d5b92e8e28e62638876696b63 (patch)
treec543cd8740d755590fb717b35f7b5fb6f7c88351
parentd56eddfd5e0f193359f93e7ef665338cace9e2e9 (diff)
downloadOpenWnn-73ba3a62d674e23d5b92e8e28e62638876696b63.tar.gz
AI 143380: am: CL 143230 am: CL 143054 Fix build breakage. sim build does not have libdl.so
Original author: dmiyakawa Merged from: //branches/cupcake/... Original author: android-build Merged from: //branches/donutburger/... Automated import of CL 143380
-rw-r--r--libs/libwnnDictionary/Android.mk8
1 files changed, 6 insertions, 2 deletions
diff --git a/libs/libwnnDictionary/Android.mk b/libs/libwnnDictionary/Android.mk
index 71292fc..cbb1a77 100644
--- a/libs/libwnnDictionary/Android.mk
+++ b/libs/libwnnDictionary/Android.mk
@@ -19,8 +19,12 @@ LOCAL_SRC_FILES := \
engine/ndcommon.c \
engine/nj_str.c
-LOCAL_SHARED_LIBRARIES := \
- libdl
+ifeq ($(TARGET_OS)-$(TARGET_SIMULATOR),linux-true)
+LOCAL_LDLIBS += -ldl
+endif
+ifneq ($(TARGET_SIMULATOR),true)
+LOCAL_SHARED_LIBRARIES += libdl
+endif
LOCAL_STATIC_LIBRARIES :=