summaryrefslogtreecommitdiff
path: root/jni/command/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'jni/command/Makefile')
-rw-r--r--jni/command/Makefile33
1 files changed, 33 insertions, 0 deletions
diff --git a/jni/command/Makefile b/jni/command/Makefile
new file mode 100644
index 0000000..0722932
--- /dev/null
+++ b/jni/command/Makefile
@@ -0,0 +1,33 @@
+CC=gcc
+CFLAGS= -g -Wall -std=c99
+CPP=g++
+CPPFLAGS= -g3 -Wall -lpthread
+
+PINYINIME_DICTBUILDER=pinyinime_dictbuilder
+
+LIBRARY_SRC= \
+ ../share/dictbuilder.cpp \
+ ../share/dictlist.cpp \
+ ../share/dicttrie.cpp \
+ ../share/lpicache.cpp \
+ ../share/mystdlib.cpp \
+ ../share/ngram.cpp \
+ ../share/searchutility.cpp \
+ ../share/spellingtable.cpp \
+ ../share/spellingtrie.cpp \
+ ../share/splparser.cpp \
+ ../share/utf16char.cpp \
+ ../share/utf16reader.cpp \
+
+all: engine
+
+engine: $(PINYINIME_DICTBUILDER)
+
+$(PINYINIME_DICTBUILDER): $(LIBRARY_SRC) pinyinime_dictbuilder.cpp
+ @$(CPP) $(CPPFLAGS) -o $@ $?
+
+
+clean:
+ -rm -rf $(PINYINIME_DICTBUILDER)
+
+.PHONY: clean