summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnton Hansson <hansson@google.com>2018-02-23 12:57:51 +0000
committerAnton Hansson <hansson@google.com>2018-03-07 11:42:04 +0000
commitbbbc88abba5c5ba67d8b2f61d9a4286e549cdf3d (patch)
tree164ab2b63592ba064d8e3f72b63f875715193a58
parentce34bb347c31d48e3d16a11da235ac127b6010c0 (diff)
downloadCaptivePortalLogin-bbbc88abba5c5ba67d8b2f61d9a4286e549cdf3d.tar.gz
frameworks/base: Set LOCAL_SDK_VERSION where possible.
This change sets LOCAL_SDK_VERSION for all packages where this is possible without breaking the build, and LOCAL_PRIVATE_PLATFORM_APIS := true otherwise. Setting one of these two will be made required soon, and this is a change in preparation for that. Not setting LOCAL_SDK_VERSION makes the app implicitly depend on the bootclasspath, which is often not required. This change effectively makes depending on private apis opt-in rather than opt-out. Test: make relevant packages Bug: 73535841 Exempt-From-Owner-Approval: Global cleanup Change-Id: I26458e41ecb84de91ac9a356a5d4bafb44f463c1
-rw-r--r--Android.mk1
1 files changed, 1 insertions, 0 deletions
diff --git a/Android.mk b/Android.mk
index 576debc..e6e0ad3 100644
--- a/Android.mk
+++ b/Android.mk
@@ -6,6 +6,7 @@ LOCAL_MODULE_TAGS := optional
LOCAL_SRC_FILES := $(call all-java-files-under, src)
LOCAL_PACKAGE_NAME := CaptivePortalLogin
+LOCAL_PRIVATE_PLATFORM_APIS := true
LOCAL_CERTIFICATE := platform
include $(BUILD_PACKAGE)