summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnton Hansson <hansson@google.com>2019-01-23 03:25:20 -0800
committerandroid-build-merger <android-build-merger@google.com>2019-01-23 03:25:20 -0800
commitacdd12e591b53419fcae822b8a0e793c794a0096 (patch)
tree31410771c98825bc1577deab0e160b868ac078ad
parent06c40b856ed1b9009a9509e76e041d4805e3090f (diff)
parentb4ac8ac0cfa6428268887c70170c176a580b43f5 (diff)
downloadModuleMetadata-acdd12e591b53419fcae822b8a0e793c794a0096.tar.gz
Move ModuleMetadata to /product
am: b4ac8ac0cf Change-Id: I4d19cd315badc30929e7f9393995493e6dbba7d6
-rw-r--r--Android.bp3
-rw-r--r--CleanSpec.mk51
2 files changed, 53 insertions, 1 deletions
diff --git a/Android.bp b/Android.bp
index cbc47a1..e8084b3 100644
--- a/Android.bp
+++ b/Android.bp
@@ -18,6 +18,7 @@ android_app {
name: "ModuleMetadata",
sdk_version: "28",
+ product_specific: true,
optimize: {
enabled: false,
},
@@ -25,4 +26,4 @@ android_app {
dex_preopt: {
enabled: false,
},
-} \ No newline at end of file
+}
diff --git a/CleanSpec.mk b/CleanSpec.mk
new file mode 100644
index 0000000..88a1f03
--- /dev/null
+++ b/CleanSpec.mk
@@ -0,0 +1,51 @@
+# Copyright (C) 2019 The Android Open Source Project
+#
+# Licensed under the Apache License, Version 2.0 (the "License");
+# you may not use this file except in compliance with the License.
+# You may obtain a copy of the License at
+#
+# http://www.apache.org/licenses/LICENSE-2.0
+#
+# Unless required by applicable law or agreed to in writing, software
+# distributed under the License is distributed on an "AS IS" BASIS,
+# WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
+# See the License for the specific language governing permissions and
+# limitations under the License.
+#
+
+# If you don't need to do a full clean build but would like to touch
+# a file or delete some intermediate files, add a clean step to the end
+# of the list. These steps will only be run once, if they haven't been
+# run before.
+#
+# E.g.:
+# $(call add-clean-step, touch -c external/sqlite/sqlite3.h)
+# $(call add-clean-step, rm -rf $(PRODUCT_OUT)/obj/STATIC_LIBRARIES/libz_intermediates)
+#
+# Always use "touch -c" and "rm -f" or "rm -rf" to gracefully deal with
+# files that are missing or have been moved.
+#
+# Use $(PRODUCT_OUT) to get to the "out/target/product/blah/" directory.
+# Use $(OUT_DIR) to refer to the "out" directory.
+#
+# If you need to re-do something that's already mentioned, just copy
+# the command and add it to the bottom of the list. E.g., if a change
+# that you made last week required touching a file and a change you
+# made today requires touching the same file, just copy the old
+# touch step and add it to the end of the list.
+#
+# ************************************************
+# NEWER CLEAN STEPS MUST BE AT THE END OF THE LIST
+# ************************************************
+
+# For example:
+#$(call add-clean-step, rm -rf $(OUT_DIR)/target/common/obj/APPS/AndroidTests_intermediates)
+#$(call add-clean-step, rm -rf $(OUT_DIR)/target/common/obj/JAVA_LIBRARIES/core_intermediates)
+#$(call add-clean-step, find $(OUT_DIR) -type f -name "IGTalkSession*" -print0 | xargs -0 rm -f)
+#$(call add-clean-step, rm -rf $(PRODUCT_OUT)/data/*)
+
+$(call add-clean-step, rm -rf $(PRODUCT_OUT)/system/app/ModuleMetadata)
+
+# ************************************************
+# NEWER CLEAN STEPS MUST BE AT THE END OF THE LIST
+# ************************************************