summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThe Android Open Source Project <initial-contribution@android.com>2009-04-29 17:39:09 -0700
committerThe Android Open Source Project <initial-contribution@android.com>2009-04-29 17:39:09 -0700
commit8533a8f88d7acdf7db347af14a5503a4cbbe9df3 (patch)
treee0ba0baa2f5144af61cb0687a0969adc7d8c9f69
parentf24bae2be7de6c341aa8752a2da68b204bdd37f6 (diff)
downloadApplicationsProvider-8533a8f88d7acdf7db347af14a5503a4cbbe9df3.tar.gz
import all files from p4
-rw-r--r--Android.mk13
-rw-r--r--MODULE_LICENSE_APACHE20
-rw-r--r--NOTICE190
-rw-r--r--res/values/strings.xml25
-rw-r--r--res/xml/searchable.xml24
-rw-r--r--src/com/android/providers/applications/ApplicationLauncher.java59
-rw-r--r--src/com/android/providers/applications/ApplicationsProvider.java339
7 files changed, 650 insertions, 0 deletions
diff --git a/Android.mk b/Android.mk
new file mode 100644
index 0000000..a70aed5
--- /dev/null
+++ b/Android.mk
@@ -0,0 +1,13 @@
+LOCAL_PATH:= $(call my-dir)
+include $(CLEAR_VARS)
+
+LOCAL_MODULE_TAGS := user development
+
+LOCAL_SRC_FILES := $(call all-subdir-java-files)
+
+LOCAL_JAVA_LIBRARIES := ext
+
+LOCAL_PACKAGE_NAME := ApplicationsProvider
+LOCAL_CERTIFICATE := shared
+
+include $(BUILD_PACKAGE)
diff --git a/MODULE_LICENSE_APACHE2 b/MODULE_LICENSE_APACHE2
new file mode 100644
index 0000000..e69de29
--- /dev/null
+++ b/MODULE_LICENSE_APACHE2
diff --git a/NOTICE b/NOTICE
new file mode 100644
index 0000000..c5b1efa
--- /dev/null
+++ b/NOTICE
@@ -0,0 +1,190 @@
+
+ Copyright (c) 2005-2008, The Android Open Source Project
+
+ Licensed under the Apache License, Version 2.0 (the "License");
+ you may not use this file except in compliance with the License.
+
+ Unless required by applicable law or agreed to in writing, software
+ distributed under the License is distributed on an "AS IS" BASIS,
+ WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
+ See the License for the specific language governing permissions and
+ limitations under the License.
+
+
+ Apache License
+ Version 2.0, January 2004
+ http://www.apache.org/licenses/
+
+ TERMS AND CONDITIONS FOR USE, REPRODUCTION, AND DISTRIBUTION
+
+ 1. Definitions.
+
+ "License" shall mean the terms and conditions for use, reproduction,
+ and distribution as defined by Sections 1 through 9 of this document.
+
+ "Licensor" shall mean the copyright owner or entity authorized by
+ the copyright owner that is granting the License.
+
+ "Legal Entity" shall mean the union of the acting entity and all
+ other entities that control, are controlled by, or are under common
+ control with that entity. For the purposes of this definition,
+ "control" means (i) the power, direct or indirect, to cause the
+ direction or management of such entity, whether by contract or
+ otherwise, or (ii) ownership of fifty percent (50%) or more of the
+ outstanding shares, or (iii) beneficial ownership of such entity.
+
+ "You" (or "Your") shall mean an individual or Legal Entity
+ exercising permissions granted by this License.
+
+ "Source" form shall mean the preferred form for making modifications,
+ including but not limited to software source code, documentation
+ source, and configuration files.
+
+ "Object" form shall mean any form resulting from mechanical
+ transformation or translation of a Source form, including but
+ not limited to compiled object code, generated documentation,
+ and conversions to other media types.
+
+ "Work" shall mean the work of authorship, whether in Source or
+ Object form, made available under the License, as indicated by a
+ copyright notice that is included in or attached to the work
+ (an example is provided in the Appendix below).
+
+ "Derivative Works" shall mean any work, whether in Source or Object
+ form, that is based on (or derived from) the Work and for which the
+ editorial revisions, annotations, elaborations, or other modifications
+ represent, as a whole, an original work of authorship. For the purposes
+ of this License, Derivative Works shall not include works that remain
+ separable from, or merely link (or bind by name) to the interfaces of,
+ the Work and Derivative Works thereof.
+
+ "Contribution" shall mean any work of authorship, including
+ the original version of the Work and any modifications or additions
+ to that Work or Derivative Works thereof, that is intentionally
+ submitted to Licensor for inclusion in the Work by the copyright owner
+ or by an individual or Legal Entity authorized to submit on behalf of
+ the copyright owner. For the purposes of this definition, "submitted"
+ means any form of electronic, verbal, or written communication sent
+ to the Licensor or its representatives, including but not limited to
+ communication on electronic mailing lists, source code control systems,
+ and issue tracking systems that are managed by, or on behalf of, the
+ Licensor for the purpose of discussing and improving the Work, but
+ excluding communication that is conspicuously marked or otherwise
+ designated in writing by the copyright owner as "Not a Contribution."
+
+ "Contributor" shall mean Licensor and any individual or Legal Entity
+ on behalf of whom a Contribution has been received by Licensor and
+ subsequently incorporated within the Work.
+
+ 2. Grant of Copyright License. Subject to the terms and conditions of
+ this License, each Contributor hereby grants to You a perpetual,
+ worldwide, non-exclusive, no-charge, royalty-free, irrevocable
+ copyright license to reproduce, prepare Derivative Works of,
+ publicly display, publicly perform, sublicense, and distribute the
+ Work and such Derivative Works in Source or Object form.
+
+ 3. Grant of Patent License. Subject to the terms and conditions of
+ this License, each Contributor hereby grants to You a perpetual,
+ worldwide, non-exclusive, no-charge, royalty-free, irrevocable
+ (except as stated in this section) patent license to make, have made,
+ use, offer to sell, sell, import, and otherwise transfer the Work,
+ where such license applies only to those patent claims licensable
+ by such Contributor that are necessarily infringed by their
+ Contribution(s) alone or by combination of their Contribution(s)
+ with the Work to which such Contribution(s) was submitted. If You
+ institute patent litigation against any entity (including a
+ cross-claim or counterclaim in a lawsuit) alleging that the Work
+ or a Contribution incorporated within the Work constitutes direct
+ or contributory patent infringement, then any patent licenses
+ granted to You under this License for that Work shall terminate
+ as of the date such litigation is filed.
+
+ 4. Redistribution. You may reproduce and distribute copies of the
+ Work or Derivative Works thereof in any medium, with or without
+ modifications, and in Source or Object form, provided that You
+ meet the following conditions:
+
+ (a) You must give any other recipients of the Work or
+ Derivative Works a copy of this License; and
+
+ (b) You must cause any modified files to carry prominent notices
+ stating that You changed the files; and
+
+ (c) You must retain, in the Source form of any Derivative Works
+ that You distribute, all copyright, patent, trademark, and
+ attribution notices from the Source form of the Work,
+ excluding those notices that do not pertain to any part of
+ the Derivative Works; and
+
+ (d) If the Work includes a "NOTICE" text file as part of its
+ distribution, then any Derivative Works that You distribute must
+ include a readable copy of the attribution notices contained
+ within such NOTICE file, excluding those notices that do not
+ pertain to any part of the Derivative Works, in at least one
+ of the following places: within a NOTICE text file distributed
+ as part of the Derivative Works; within the Source form or
+ documentation, if provided along with the Derivative Works; or,
+ within a display generated by the Derivative Works, if and
+ wherever such third-party notices normally appear. The contents
+ of the NOTICE file are for informational purposes only and
+ do not modify the License. You may add Your own attribution
+ notices within Derivative Works that You distribute, alongside
+ or as an addendum to the NOTICE text from the Work, provided
+ that such additional attribution notices cannot be construed
+ as modifying the License.
+
+ You may add Your own copyright statement to Your modifications and
+ may provide additional or different license terms and conditions
+ for use, reproduction, or distribution of Your modifications, or
+ for any such Derivative Works as a whole, provided Your use,
+ reproduction, and distribution of the Work otherwise complies with
+ the conditions stated in this License.
+
+ 5. Submission of Contributions. Unless You explicitly state otherwise,
+ any Contribution intentionally submitted for inclusion in the Work
+ by You to the Licensor shall be under the terms and conditions of
+ this License, without any additional terms or conditions.
+ Notwithstanding the above, nothing herein shall supersede or modify
+ the terms of any separate license agreement you may have executed
+ with Licensor regarding such Contributions.
+
+ 6. Trademarks. This License does not grant permission to use the trade
+ names, trademarks, service marks, or product names of the Licensor,
+ except as required for reasonable and customary use in describing the
+ origin of the Work and reproducing the content of the NOTICE file.
+
+ 7. Disclaimer of Warranty. Unless required by applicable law or
+ agreed to in writing, Licensor provides the Work (and each
+ Contributor provides its Contributions) on an "AS IS" BASIS,
+ WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or
+ implied, including, without limitation, any warranties or conditions
+ of TITLE, NON-INFRINGEMENT, MERCHANTABILITY, or FITNESS FOR A
+ PARTICULAR PURPOSE. You are solely responsible for determining the
+ appropriateness of using or redistributing the Work and assume any
+ risks associated with Your exercise of permissions under this License.
+
+ 8. Limitation of Liability. In no event and under no legal theory,
+ whether in tort (including negligence), contract, or otherwise,
+ unless required by applicable law (such as deliberate and grossly
+ negligent acts) or agreed to in writing, shall any Contributor be
+ liable to You for damages, including any direct, indirect, special,
+ incidental, or consequential damages of any character arising as a
+ result of this License or out of the use or inability to use the
+ Work (including but not limited to damages for loss of goodwill,
+ work stoppage, computer failure or malfunction, or any and all
+ other commercial damages or losses), even if such Contributor
+ has been advised of the possibility of such damages.
+
+ 9. Accepting Warranty or Additional Liability. While redistributing
+ the Work or Derivative Works thereof, You may choose to offer,
+ and charge a fee for, acceptance of support, warranty, indemnity,
+ or other liability obligations and/or rights consistent with this
+ License. However, in accepting such obligations, You may act only
+ on Your own behalf and on Your sole responsibility, not on behalf
+ of any other Contributor, and only if You agree to indemnify,
+ defend, and hold each Contributor harmless for any liability
+ incurred by, or claims asserted against, such Contributor by reason
+ of your accepting any such warranty or additional liability.
+
+ END OF TERMS AND CONDITIONS
+
diff --git a/res/values/strings.xml b/res/values/strings.xml
new file mode 100644
index 0000000..a5d29aa
--- /dev/null
+++ b/res/values/strings.xml
@@ -0,0 +1,25 @@
+<?xml version="1.0" encoding="utf-8"?>
+<!-- Copyright (C) 2008 The Android Open Source Project
+
+ Licensed under the Apache License, Version 2.0 (the "License");
+ you may not use this file except in compliance with the License.
+ You may obtain a copy of the License at
+
+ http://www.apache.org/licenses/LICENSE-2.0
+
+ Unless required by applicable law or agreed to in writing, software
+ distributed under the License is distributed on an "AS IS" BASIS,
+ WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
+ See the License for the specific language governing permissions and
+ limitations under the License.
+-->
+<resources xmlns:xliff="urn:oasis:names:tc:xliff:document:1.2">
+
+
+ <!-- Search label for applications. -->
+ <string name="search_label">Applications</string>
+
+ <!-- Description line displayed for an application entry in the search suggest list. -->
+ <string name="application_desc">Application</string>
+
+</resources>
diff --git a/res/xml/searchable.xml b/res/xml/searchable.xml
new file mode 100644
index 0000000..a95729e
--- /dev/null
+++ b/res/xml/searchable.xml
@@ -0,0 +1,24 @@
+<?xml version="1.0" encoding="utf-8"?>
+<!-- Copyright (C) 2008 The Android Open Source Project
+
+ Licensed under the Apache License, Version 2.0 (the "License");
+ you may not use this file except in compliance with the License.
+ You may obtain a copy of the License at
+
+ http://www.apache.org/licenses/LICENSE-2.0
+
+ Unless required by applicable law or agreed to in writing, software
+ distributed under the License is distributed on an "AS IS" BASIS,
+ WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
+ See the License for the specific language governing permissions and
+ limitations under the License.
+-->
+
+<searchable xmlns:android="http://schemas.android.com/apk/res/android"
+ android:icon="@android:drawable/sym_def_app_icon"
+ android:label="@string/search_label"
+ android:searchMode="showSearchLabelAsBadge"
+ android:searchSuggestAuthority="applications"
+ android:searchSuggestIntentAction="android.intent.action.MAIN"
+>
+</searchable>
diff --git a/src/com/android/providers/applications/ApplicationLauncher.java b/src/com/android/providers/applications/ApplicationLauncher.java
new file mode 100644
index 0000000..8463fb6
--- /dev/null
+++ b/src/com/android/providers/applications/ApplicationLauncher.java
@@ -0,0 +1,59 @@
+/*
+ * Copyright (C) 2009 The Android Open Source Project
+ *
+ * Licensed under the Apache License, Version 2.0 (the "License");
+ * you may not use this file except in compliance with the License.
+ * You may obtain a copy of the License at
+ *
+ * http://www.apache.org/licenses/LICENSE-2.0
+ *
+ * Unless required by applicable law or agreed to in writing, software
+ * distributed under the License is distributed on an "AS IS" BASIS,
+ * WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
+ * See the License for the specific language governing permissions and
+ * limitations under the License.
+ */
+
+package com.android.providers.applications;
+
+import android.app.Activity;
+import android.content.ComponentName;
+import android.content.Intent;
+import android.net.Uri;
+import android.os.Bundle;
+import android.util.Log;
+
+/**
+ * This class is purely here to get launch intents.
+ */
+public class ApplicationLauncher extends Activity {
+ private static final String TAG = ApplicationLauncher.class.getSimpleName();
+
+ @Override
+ protected void onCreate(Bundle savedInstanceState) {
+ super.onCreate(savedInstanceState);
+ Intent intent = getIntent();
+ boolean handled = false;
+ if (intent != null) {
+ String action = intent.getAction();
+ if (Intent.ACTION_MAIN.equals(action)) {
+ // Launch the component given in the query string
+ Uri contentUri = intent.getData();
+ ComponentName componentName = ApplicationsProvider.getComponentName(contentUri);
+ if (componentName != null) {
+ Intent launchIntent = new Intent(Intent.ACTION_MAIN);
+ launchIntent.setFlags(Intent.FLAG_ACTIVITY_NEW_TASK |
+ Intent.FLAG_ACTIVITY_RESET_TASK_IF_NEEDED);
+ launchIntent.setComponent(componentName);
+ startActivity(launchIntent);
+ handled = true;
+ }
+ }
+ }
+ if (!handled) {
+ Log.w(TAG, "Unhandled intent: " + intent);
+ }
+ finish();
+ }
+
+}
diff --git a/src/com/android/providers/applications/ApplicationsProvider.java b/src/com/android/providers/applications/ApplicationsProvider.java
new file mode 100644
index 0000000..11e5d4a
--- /dev/null
+++ b/src/com/android/providers/applications/ApplicationsProvider.java
@@ -0,0 +1,339 @@
+/*
+ * Copyright (C) 2009 The Android Open Source Project
+ *
+ * Licensed under the Apache License, Version 2.0 (the "License");
+ * you may not use this file except in compliance with the License.
+ * You may obtain a copy of the License at
+ *
+ * http://www.apache.org/licenses/LICENSE-2.0
+ *
+ * Unless required by applicable law or agreed to in writing, software
+ * distributed under the License is distributed on an "AS IS" BASIS,
+ * WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
+ * See the License for the specific language governing permissions and
+ * limitations under the License.
+ */
+
+package com.android.providers.applications;
+
+import android.app.SearchManager;
+import android.content.BroadcastReceiver;
+import android.content.ComponentName;
+import android.content.ContentProvider;
+import android.content.ContentResolver;
+import android.content.ContentValues;
+import android.content.Context;
+import android.content.Intent;
+import android.content.IntentFilter;
+import android.content.UriMatcher;
+import android.content.pm.PackageManager;
+import android.content.pm.ResolveInfo;
+import android.database.Cursor;
+import android.database.DatabaseUtils;
+import android.database.sqlite.SQLiteDatabase;
+import android.database.sqlite.SQLiteQueryBuilder;
+import android.net.Uri;
+import android.provider.Applications;
+import android.text.TextUtils;
+import android.util.Log;
+
+import java.util.HashMap;
+import java.util.List;
+
+/**
+ * Fetches the list of applications installed on the phone to provide search suggestions.
+ * If the functionality of this provider changes, the documentation at
+ * {@link android.provider.Applications} should be updated.
+ */
+public class ApplicationsProvider extends ContentProvider {
+
+ private static final boolean DBG = false;
+
+ private static final String TAG = "ApplicationsProvider";
+
+ private static final UriMatcher sURIMatcher = new UriMatcher(UriMatcher.NO_MATCH);
+ private static final int SEARCH_SUGGEST = 0;
+
+ static {
+ sURIMatcher.addURI(Applications.AUTHORITY, SearchManager.SUGGEST_URI_PATH_QUERY,
+ SEARCH_SUGGEST);
+ sURIMatcher.addURI(Applications.AUTHORITY, SearchManager.SUGGEST_URI_PATH_QUERY + "/*",
+ SEARCH_SUGGEST);
+ };
+
+ // TODO: Move these to android.provider.Applications?
+ public static final String _ID = "_id";
+ public static final String NAME = "name";
+ public static final String DESCRIPTION = "description";
+ public static final String PACKAGE = "package";
+ public static final String CLASS = "class";
+ public static final String ICON = "icon";
+
+ private static final String APPLICATIONS_TABLE = "applications";
+
+ private static final HashMap<String, String> sSearchSuggestionsProjectionMap =
+ buildSuggestionsProjectionMap();
+
+ private SQLiteDatabase mDb;
+
+ // Broadcast receiver for updating applications list.
+ private BroadcastReceiver mBroadcastReceiver = new BroadcastReceiver() {
+ @Override
+ public void onReceive(Context context, Intent intent) {
+ String action = intent.getAction();
+ if (Intent.ACTION_PACKAGE_ADDED.equals(action)
+ || Intent.ACTION_PACKAGE_REMOVED.equals(action)
+ || Intent.ACTION_PACKAGE_CHANGED.equals(action)) {
+ // TODO: Instead of rebuilding the whole list on every change,
+ // just add, remove or update the application that has changed.
+ // Adding and updating seem tricky, since I can't see an easy way to list the
+ // launchable activities in a given package.
+ updateApplicationsList();
+ }
+ }
+ };
+
+ @Override
+ public boolean onCreate() {
+ createDatabase();
+ registerBroadcastReceiver();
+ updateApplicationsList();
+ return true;
+ }
+
+ /**
+ * Creates an in-memory database for storing application info.
+ */
+ private void createDatabase() {
+ mDb = SQLiteDatabase.create(null);
+ mDb.execSQL("CREATE TABLE IF NOT EXISTS " + APPLICATIONS_TABLE + " ("+
+ _ID + " INTEGER PRIMARY KEY AUTOINCREMENT," +
+ NAME + " TEXT COLLATE LOCALIZED," +
+ DESCRIPTION + " description TEXT," +
+ PACKAGE + " TEXT," +
+ CLASS + " TEXT," +
+ ICON + " TEXT" +
+ ");");
+ // Needed for efficient update and remove
+ mDb.execSQL("CREATE INDEX applicationsComponentIndex ON " + APPLICATIONS_TABLE + " ("
+ + PACKAGE + "," + CLASS + ");");
+ // Maps token from the app name to records in the applications table
+ mDb.execSQL("CREATE TABLE applicationsLookup (" +
+ "token TEXT," +
+ "source INTEGER REFERENCES " + APPLICATIONS_TABLE + "(" + _ID + ")" +
+ ");");
+ mDb.execSQL("CREATE INDEX applicationsLookupIndex ON applicationsLookup (" +
+ "token," +
+ "source" +
+ ");");
+ // Triggers to keep the applicationsLookup table up to date
+ mDb.execSQL("CREATE TRIGGER applicationsLookup_update UPDATE OF " + NAME + " ON " +
+ APPLICATIONS_TABLE + " " +
+ "BEGIN " +
+ "DELETE FROM applicationsLookup WHERE source = new." + _ID + ";" +
+ "SELECT _TOKENIZE('applicationsLookup', new." + _ID + ", new." + NAME + ", ' ');" +
+ "END");
+ mDb.execSQL("CREATE TRIGGER applicationsLookup_insert AFTER INSERT ON " +
+ APPLICATIONS_TABLE + " " +
+ "BEGIN " +
+ "SELECT _TOKENIZE('applicationsLookup', new." + _ID + ", new." + NAME + ", ' ');" +
+ "END");
+ mDb.execSQL("CREATE TRIGGER applicationsLookup_delete DELETE ON " +
+ APPLICATIONS_TABLE + " " +
+ "BEGIN " +
+ "DELETE FROM applicationsLookup WHERE source = old." + _ID + ";" +
+ "END");
+ }
+
+ /**
+ * Registers a receiver which will be notified when packages are added, removed,
+ * or changed.
+ */
+ private void registerBroadcastReceiver() {
+ IntentFilter packageFilter = new IntentFilter();
+ packageFilter.addAction(Intent.ACTION_PACKAGE_ADDED);
+ packageFilter.addAction(Intent.ACTION_PACKAGE_REMOVED);
+ packageFilter.addAction(Intent.ACTION_PACKAGE_CHANGED);
+ packageFilter.addDataScheme("package");
+ getContext().registerReceiver(mBroadcastReceiver, packageFilter);
+ }
+
+ /**
+ * This will always return {@link SearchManager#SUGGEST_MIME_TYPE} as this
+ * provider is purely to provide suggestions.
+ */
+ @Override
+ public String getType(Uri uri) {
+ return SearchManager.SUGGEST_MIME_TYPE;
+ }
+
+ /**
+ * Queries for a given search term and returns a cursor containing
+ * suggestions ordered by best match.
+ */
+ @Override
+ public Cursor query(Uri uri, String[] projectionIn, String selection,
+ String[] selectionArgs, String sortOrder) {
+
+ if (sURIMatcher.match(uri) != SEARCH_SUGGEST) {
+ throw new IllegalArgumentException("Unknown URL " + uri);
+ }
+
+ // Get the search text
+ String query = null;
+ if (uri.getPathSegments().size() > 1) {
+ query = uri.getLastPathSegment().toLowerCase();
+ }
+ if (TextUtils.isEmpty(query)) {
+ return null;
+ }
+
+ // Build SQL query
+ SQLiteQueryBuilder qb = new SQLiteQueryBuilder();
+ qb.setTables(APPLICATIONS_TABLE);
+ qb.setProjectionMap(sSearchSuggestionsProjectionMap);
+ qb.appendWhere(buildApplicationsLookupWhereClause(query));
+
+ Cursor cursor = qb.query(mDb, projectionIn, selection, selectionArgs,
+ null, null, sortOrder);
+ return cursor;
+ }
+
+ // Stolen from ContactsProvider.buildPeopleLookupWhereClause(String)
+ @SuppressWarnings("deprecation")
+ private String buildApplicationsLookupWhereClause(String filterParam) {
+ StringBuilder filter = new StringBuilder(
+ APPLICATIONS_TABLE + "." + _ID +
+ " IN (SELECT source FROM applicationsLookup WHERE token GLOB ");
+ // NOTE: Query parameters won't work here since the SQL compiler
+ // needs to parse the actual string to know that it can use the
+ // index to do a prefix scan.
+ DatabaseUtils.appendEscapedSQLString(filter,
+ DatabaseUtils.getHexCollationKey(filterParam) + "*");
+ filter.append(')');
+ return filter.toString();
+ }
+
+ private static HashMap<String, String> buildSuggestionsProjectionMap() {
+ HashMap<String, String> map = new HashMap<String, String>();
+ map.put(_ID, _ID);
+ map.put(SearchManager.SUGGEST_COLUMN_TEXT_1,
+ NAME + " AS " + SearchManager.SUGGEST_COLUMN_TEXT_1);
+ map.put(SearchManager.SUGGEST_COLUMN_TEXT_2,
+ DESCRIPTION + " AS " + SearchManager.SUGGEST_COLUMN_TEXT_2);
+ map.put(SearchManager.SUGGEST_COLUMN_INTENT_DATA,
+ "'content://" + Applications.AUTHORITY + "/applications/'"
+ + " || " + PACKAGE + " || '/' || " + CLASS
+ + " AS " + SearchManager.SUGGEST_COLUMN_INTENT_DATA);
+ map.put(SearchManager.SUGGEST_COLUMN_ICON_1,
+ ICON + " AS " + SearchManager.SUGGEST_COLUMN_ICON_1);
+ map.put(SearchManager.SUGGEST_COLUMN_ICON_2,
+ "NULL AS " + SearchManager.SUGGEST_COLUMN_ICON_2);
+ return map;
+ }
+
+ /**
+ * Updates the cached list of installed applications.
+ */
+ private void updateApplicationsList() {
+ if (DBG) Log.d(TAG, "Updating database...");
+
+ DatabaseUtils.InsertHelper inserter =
+ new DatabaseUtils.InsertHelper(mDb, APPLICATIONS_TABLE);
+ int nameCol = inserter.getColumnIndex(NAME);
+ int descriptionCol = inserter.getColumnIndex(DESCRIPTION);
+ int packageCol = inserter.getColumnIndex(PACKAGE);
+ int classCol = inserter.getColumnIndex(CLASS);
+ int iconCol = inserter.getColumnIndex(ICON);
+
+ mDb.beginTransaction();
+ try {
+ mDb.execSQL("DELETE FROM " + APPLICATIONS_TABLE);
+ String description = getContext().getString(R.string.application_desc);
+ // Iterate and find all the activities which have the LAUNCHER category set.
+ Intent mainIntent = new Intent(Intent.ACTION_MAIN, null);
+ mainIntent.addCategory(Intent.CATEGORY_LAUNCHER);
+ final PackageManager manager = getContext().getPackageManager();
+ for (ResolveInfo info : manager.queryIntentActivities(mainIntent, 0)) {
+ String title = info.loadLabel(manager).toString();
+ if (TextUtils.isEmpty(title)) {
+ title = info.activityInfo.name;
+ }
+ // Use a resource Uri for the icon.
+ String icon = new Uri.Builder()
+ .scheme(ContentResolver.SCHEME_ANDROID_RESOURCE)
+ .authority(info.activityInfo.applicationInfo.packageName)
+ .encodedPath(String.valueOf(info.activityInfo.getIconResource()))
+ .toString();
+ inserter.prepareForInsert();
+ inserter.bind(nameCol, title);
+ inserter.bind(descriptionCol, description);
+ inserter.bind(packageCol, info.activityInfo.applicationInfo.packageName);
+ inserter.bind(classCol, info.activityInfo.name);
+ inserter.bind(iconCol, icon);
+ inserter.execute();
+ }
+ mDb.setTransactionSuccessful();
+ } finally {
+ mDb.endTransaction();
+ }
+ if (DBG) Log.d(TAG, "Finished updating database.");
+ }
+
+
+ @Override
+ public Uri insert(Uri uri, ContentValues values) {
+ throw new UnsupportedOperationException();
+ }
+
+ @Override
+ public int update(Uri uri, ContentValues values, String selection,
+ String[] selectionArgs) {
+ throw new UnsupportedOperationException();
+ }
+
+ @Override
+ public int delete(Uri uri, String selection, String[] selectionArgs) {
+ throw new UnsupportedOperationException();
+ }
+
+ /**
+ * Gets the application component name from an application URI.
+ * TODO: Move this to android.provider.Applications?
+ *
+ * @param appUri A URI of the form
+ * "content://applications/applications/&lt;packageName&gt;/&lt;className&gt;".
+ * @return The component name for the application, or
+ * <code>null</null> if the given URI was <code>null</code>
+ * or malformed.
+ */
+ public static ComponentName getComponentName(Uri appUri) {
+ if (appUri == null) {
+ return null;
+ }
+ List<String> pathSegments = appUri.getPathSegments();
+ if (pathSegments.size() < 3) {
+ return null;
+ }
+ String packageName = pathSegments.get(1);
+ String name = pathSegments.get(2);
+ return new ComponentName(packageName, name);
+ }
+
+ /**
+ * Gets the URI for an application.
+ * TODO: Move this to android.provider.Applications?
+ *
+ * @param packageName The name of the application's package.
+ * @param className The class name of the application.
+ * @return A URI of the form
+ * "content://applications/applications/&lt;packageName&gt;/&lt;className&gt;".
+ */
+ public static Uri getUri(String packageName, String className) {
+ return Applications.CONTENT_URI.buildUpon()
+ .appendEncodedPath("applications")
+ .appendPath(packageName)
+ .appendPath(className)
+ .build();
+ }
+}