summaryrefslogtreecommitdiff
path: root/Android.mk
diff options
context:
space:
mode:
authorPeter Visontay <pvisontay@google.com>2010-11-19 13:14:13 +0000
committerPeter Visontay <pvisontay@google.com>2011-01-28 11:03:50 +0000
commit62a6b1f913bdfa1f7f53fad055cd62c3cfb90100 (patch)
tree55020b6e74848efaa3d815e4a98d0a8f02f5a857 /Android.mk
parent6bb3c8a364e4f8c291f8e2a1c1cbd2ab2042d8ba (diff)
downloadApplicationsProvider-62a6b1f913bdfa1f7f53fad055cd62c3cfb90100.tar.gz
Added new URI for launch count updates to ApplicationsProvider.
Tested with automated tests + manually: 1. Installed ApplicationsProvider (with a clean database containing 0 as each app's current launch count). 2. Typed "g" into QSB. App suggestions: Gallery, Gmail (ranked alphabetically). 3. Clicked on the "Google Search" app to launch it and by doing so increase its launch count. 4. Cleared the QSB shortcuts (QSB created one for Google Search when it was launched). 5. Reinstalled ApplicationsProvider so the in-memory values would be lost. 6. Typed "g" into QSB. app suggestions: Google Search, Gallery (ranked by launch count). Bug: 1847330 Change-Id: I4125b34a1923fe5866c52bf77218974ed14a38bc
Diffstat (limited to 'Android.mk')
-rw-r--r--Android.mk7
1 files changed, 5 insertions, 2 deletions
diff --git a/Android.mk b/Android.mk
index f436b87..c7e96db 100644
--- a/Android.mk
+++ b/Android.mk
@@ -3,11 +3,14 @@ include $(CLEAR_VARS)
LOCAL_MODULE_TAGS := optional
-LOCAL_SRC_FILES := $(call all-subdir-java-files)
+LOCAL_SRC_FILES := $(call all-java-files-under, src)
-LOCAL_JAVA_LIBRARIES := ext
+LOCAL_JAVA_LIBRARIES := ext guava
LOCAL_PACKAGE_NAME := ApplicationsProvider
LOCAL_CERTIFICATE := shared
include $(BUILD_PACKAGE)
+
+# Also build our test apk
+include $(call all-makefiles-under,$(LOCAL_PATH))