summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPaul Duffin <paulduffin@google.com>2017-01-17 14:49:42 +0000
committerPaul Duffin <paulduffin@google.com>2017-01-18 15:33:09 +0000
commit10260bd83b6365a02ed0224c8fe23011bfd6a7c1 (patch)
treea7616816dcd5a2b44419ee1e65b938bbc3de46e2
parent875f07b8df731552bbf4d441735bca94bf2bc991 (diff)
downloadBlockedNumberProvider-10260bd83b6365a02ed0224c8fe23011bfd6a7c1.tar.gz
Prepare for removal of legacy-test from default targets
In preparation for removing junit classes from the Android API the legacy-test target will be removed from the TARGET_DEFAULT_JAVA_LIBRARIES. This change adds explicit dependencies on junit and/or legacy-android-test to ensure that modules will compile properly once it is removed. Bug: 30188076 Test: make checkbuild Change-Id: I1f92750773e555cd3f09294e27a21f45888c8ea5
-rw-r--r--tests/Android.mk3
1 files changed, 2 insertions, 1 deletions
diff --git a/tests/Android.mk b/tests/Android.mk
index 2c81c5d..8db8e4f 100644
--- a/tests/Android.mk
+++ b/tests/Android.mk
@@ -6,7 +6,8 @@ LOCAL_MODULE_TAGS := tests
LOCAL_STATIC_JAVA_LIBRARIES := \
mockito-target-minus-junit4 \
- android-support-test
+ android-support-test \
+ legacy-android-test
LOCAL_JAVA_LIBRARIES := android.test.runner