summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPaul Duffin <paulduffin@google.com>2017-01-17 14:49:42 +0000
committerPaul Duffin <paulduffin@google.com>2017-01-18 15:34:12 +0000
commitbce5cb3248bb340c97d1e3af323617f0630fc4ef (patch)
tree69efcdc14a9262ecd8f0eabf06965d0e46f1a495
parentefa2852fb99356ac7fa273d3a9db559f50f6f834 (diff)
downloadBlockedNumberProvider-bce5cb3248bb340c97d1e3af323617f0630fc4ef.tar.gz
Prepare for removal of legacy-test from default targetsandroid-o-preview-1o-preview
In preparation for removing junit classes from the Android API the legacy-test target will be removed from the TARGET_DEFAULT_JAVA_LIBRARIES. This change adds explicit dependencies on junit and/or legacy-android-test to ensure that modules will compile properly once it is removed. (cherry picked from 10260bd83b6365a02ed0224c8fe23011bfd6a7c1) Bug: 30188076 Test: make checkbuild Merged-In: I1f92750773e555cd3f09294e27a21f45888c8ea5 Change-Id: Idc6775cefb9e2abe999e20900799af8cab563595
-rw-r--r--tests/Android.mk3
1 files changed, 2 insertions, 1 deletions
diff --git a/tests/Android.mk b/tests/Android.mk
index 8f500de..702644a 100644
--- a/tests/Android.mk
+++ b/tests/Android.mk
@@ -6,7 +6,8 @@ LOCAL_MODULE_TAGS := tests
LOCAL_STATIC_JAVA_LIBRARIES := \
mockito-target \
- android-support-test
+ android-support-test \
+ legacy-android-test
LOCAL_JAVA_LIBRARIES := android.test.runner