aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSimran Basi <sbasi@google.com>2017-03-15 15:15:44 -0700
committerSimran Basi <sbasi@google.com>2017-03-15 15:15:44 -0700
commit875cbe0140d6eaf1410022d318f7e45f81f260ae (patch)
tree961684c3d9d274612f0049273b00b6819c1d4c9b
parent6d6be558693ec480b281e6614894f22ca5161944 (diff)
downloadContactsProvider-875cbe0140d6eaf1410022d318f7e45f81f260ae.tar.gz
packages/providers/ContactsProvider: Add APCT tests to the device-tests suite.
This CL adds the APCT tests within this project to a similar suite as CTS known as device-tests. The current method of running APCT tests in the infrastructure is unaffected. Bug: 35882476 Test: `make dist device-tests -j` and local builds of continuous_instrumentation_tests & continuous_native_tests Change-Id: Iff7fed94ed30176930d3e93279b7055053757432
-rw-r--r--tests/Android.mk1
-rw-r--r--tests2/Android.mk1
2 files changed, 2 insertions, 0 deletions
diff --git a/tests/Android.mk b/tests/Android.mk
index b3aaa236..8df1d6d4 100644
--- a/tests/Android.mk
+++ b/tests/Android.mk
@@ -16,6 +16,7 @@ LOCAL_JAVA_LIBRARIES := android.test.runner
LOCAL_SRC_FILES := $(call all-java-files-under, src)
LOCAL_PACKAGE_NAME := ContactsProviderTests
+LOCAL_COMPATIBILITY_SUITE := device-tests
LOCAL_INSTRUMENTATION_FOR := ContactsProvider
LOCAL_CERTIFICATE := shared
diff --git a/tests2/Android.mk b/tests2/Android.mk
index 4209f0e6..bb4443f3 100644
--- a/tests2/Android.mk
+++ b/tests2/Android.mk
@@ -30,6 +30,7 @@ LOCAL_JAVA_LIBRARIES := android.test.runner
LOCAL_SRC_FILES := $(call all-java-files-under, src)
LOCAL_PACKAGE_NAME := ContactsProviderTests2
+LOCAL_COMPATIBILITY_SUITE := device-tests
LOCAL_INSTRUMENTATION_FOR := ContactsProvider
LOCAL_CERTIFICATE := shared