aboutsummaryrefslogtreecommitdiff
path: root/Android.bp
diff options
context:
space:
mode:
authorSasha Smundak <asmundak@google.com>2019-01-10 19:04:14 -0800
committerSasha Smundak <asmundak@google.com>2019-01-10 19:04:14 -0800
commit3a6001871735fa29126a57cf2506fb74304d6843 (patch)
treef6dee35be6c320c1af60a1d58952bd6db75a4cdc /Android.bp
parentf4e2db9bf5ccb5372965a425c1eb5d79c8c0ad6e (diff)
downloadContactsProvider-3a6001871735fa29126a57cf2506fb74304d6843.tar.gz
Convert Android.mk file to Android.bp
See build/soong/README.md for more information. Bug: 122333363 Test: treehugger Change-Id: Idb03dd371284aec57ed356c6091965672b7b95f5
Diffstat (limited to 'Android.bp')
-rw-r--r--Android.bp32
1 files changed, 32 insertions, 0 deletions
diff --git a/Android.bp b/Android.bp
new file mode 100644
index 00000000..b6bddce9
--- /dev/null
+++ b/Android.bp
@@ -0,0 +1,32 @@
+android_app {
+ name: "ContactsProvider",
+ // Only compile source java files in this apk.
+ srcs: [
+ "src/**/*.java",
+ "src/com/android/providers/contacts/EventLogTags.logtags",
+ ],
+ libs: [
+ "ext",
+ "telephony-common",
+ ],
+ static_libs: [
+ "android-common",
+ "com.android.vcard",
+ "guava",
+ ],
+
+ // The Jacoco tool analyzes code coverage when running unit tests on the
+ // application. This configuration line selects which packages will be analyzed,
+ // leaving out code which is tested by other means (e.g. static libraries) that
+ // would dilute the coverage results. These options do not affect regular
+ // production builds.
+ jacoco: {
+ include_filter: ["com.android.providers.contacts.*"],
+ },
+ platform_apis: true,
+ certificate: "shared",
+ privileged: true,
+ optimize: {
+ proguard_flags_files: ["proguard.flags"],
+ },
+}