aboutsummaryrefslogtreecommitdiff
path: root/Android.mk
diff options
context:
space:
mode:
authorJeff Hamilton <jham@android.com>2009-04-23 02:29:07 -0500
committerJeff Hamilton <jham@android.com>2009-04-24 01:32:03 -0500
commit4f864360c24bd26c111bf38a035e8e2d2609e84a (patch)
treed0d21e458d2232da0c09dfb326465a22aae16a3f /Android.mk
parent1436fbe75260fb1888145e17ed3e81f2b3a7a255 (diff)
downloadContactsProvider-4f864360c24bd26c111bf38a035e8e2d2609e84a.tar.gz
First pass at new ContactsProvider.
It's very basic right now, but shows the general layout that I'm thinking of for the schema and how the data types are defined. The test app just reads the display names and puts them in a list, not very useful since you have to add data with the sqlite3 tool for now.
Diffstat (limited to 'Android.mk')
-rw-r--r--Android.mk16
1 files changed, 16 insertions, 0 deletions
diff --git a/Android.mk b/Android.mk
new file mode 100644
index 00000000..7f1871a5
--- /dev/null
+++ b/Android.mk
@@ -0,0 +1,16 @@
+LOCAL_PATH:= $(call my-dir)
+include $(CLEAR_VARS)
+
+LOCAL_MODULE_TAGS := user
+
+LOCAL_SRC_FILES := $(call all-subdir-java-files)
+
+LOCAL_JAVA_LIBRARIES := ext
+
+LOCAL_PACKAGE_NAME := ContactsProvider2
+LOCAL_CERTIFICATE := shared
+
+include $(BUILD_PACKAGE)
+
+# Use the following include to make our test apk.
+include $(call all-makefiles-under,$(LOCAL_PATH))